summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 11:51:19 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:13:49 +0200
commit43a5c177379f580b804f843ace179d68a8b7fc03 (patch)
tree2fffb12954bb725cd7e15ea22e3006ab6babe2fe
parent1db1e3c79efd6c61632a68a003d0979d0ad5b35f (diff)
gnu: Add go-github-com-libp2p-go-libp2p-protocol.
* gnu/packages/golang.scm (go-github-com-libp2p-go-libp2p-protocol): New variable.
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4c36f1eaaf..4b2c30f558 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2941,3 +2941,28 @@ required by Go's standard Hash interface.")
(synopsis "PKI based identities for use in go-libp2p")
(description "PKI based identities for use in @command{go-libp2p}.")
(license license:expat))))
+
+(define-public go-github-com-libp2p-go-libp2p-protocol
+ (let ((commit "b29f3d97e3a2fb8b29c5d04290e6cb5c5018004b")
+ (revision "0"))
+ (package
+ (name "go-github-com-libp2p-go-libp2p-protocol")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libp2p/go-libp2p-protocol.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xgjfnx9zcqglg9li29wdqywsp8hz22wx6phns9zscni2jsfidld"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path
+ "github.com/libp2p/go-libp2p-protocol"))
+ (home-page "https://github.com/libp2p/go-libp2p-protocol")
+ (synopsis "Type for protocol strings in Golang")
+ (description "Just a type for protocol strings. Nothing more.")
+ (license license:expat))))