summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 11:38:54 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:13:49 +0200
commit71f3680499d578946193af3db08f19688fb48ce7 (patch)
tree124ded7181399ba2dc1eec149f91628bcc7a35d8
parentff2d11c3ce8dc1fb3715bffbc058fa4ab22226b1 (diff)
gnu: Add go-github-com-libp2p-go-libp2p-crypto.
* gnu/packages/golang.scm (go-github-com-libp2p-go-libp2p-crypto): New variable.
-rw-r--r--gnu/packages/golang.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1631c0bc72..4ee4a01b43 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2732,3 +2732,33 @@ This package uses Golang assembly. The AVX512 version is based on the Intel's
implementations are described in \"Fast SHA-256 Implementations on Intel
Architecture Processors\" by J. Guilford et al.")
(license license:asl2.0))))
+
+(define-public go-github-com-libp2p-go-libp2p-crypto
+ (let ((commit "7240b40a3ddc47c4d17c15baabcbe45e5219171b")
+ (revision "0"))
+ (package
+ (name "go-github-com-libp2p-go-libp2p-crypto")
+ (version (git-version "2.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libp2p/go-libp2p-crypto.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qwpy57qv5143l9dlfwfvpqsxdd2i4zwnawx1w4pmgxxim3nw1wb"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/libp2p/go-libp2p-crypto"))
+ (native-inputs
+ `(("go-golang-org-x-crypto-ed25519" ,go-golang-org-x-crypto-ed25519)
+ ("go-github-com-btcsuite-btcd-btcec" ,go-github-com-btcsuite-btcd-btcec)
+ ("go-github-com-gogo-protobuf-proto" ,go-github-com-gogo-protobuf-proto)
+ ("go-github-com-minio-sha256-simd" ,go-github-com-minio-sha256-simd)))
+ (home-page
+ "https://github.com/libp2p/go-libp2p-crypto")
+ (synopsis "Various cryptographic utilities used by IPFS")
+ (description "Various cryptographic utilities used by IPFS")
+ (license license:expat))))