summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:08:48 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:13:50 +0200
commit7bd9020e48467fb05950c84eaf29460b449d7c1c (patch)
treec20ac1c4bdee003c0a6b75c291df15f303f3ca46
parentb5bb0b500bf0bc14bbb5d554a75d4f46f1d74795 (diff)
gnu: Add go-github-com-whyrusleeping-json-filter.
* gnu/packages/golang.scm (go-github-com-whyrusleeping-json-filter): New variable.
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e07bf6c8e5..34d60110c4 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3234,3 +3234,29 @@ as conversion to and from @command{net.Addr}.")
building command line apps in Go. The goal is to enable developers to write
fast and distributable command line applications in an expressive way.")
(license license:expat))))
+
+(define-public go-github-com-whyrusleeping-json-filter
+ (let ((commit "ff25329a9528f01c5175414f16cc0a6a162a5b8b")
+ (revision "0"))
+ (package
+ (name "go-github-com-whyrusleeping-json-filter")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/whyrusleeping/json-filter.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0cai0drvx4c8j686l908vpcsz3mw3vxi3ziz94b0f3c5ylpj07j7"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path
+ "github.com/whyrusleeping/json-filter"))
+ (home-page "https://github.com/whyrusleeping/json-filter")
+ (synopsis "Library to query JSON objects marshalled into map[string]interface")
+ (description "A library to query JSON objects marshalled into
+@command{map[string]interface{}}.")
+ (license license:expat))))