summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:07:04 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:13:50 +0200
commitb5bb0b500bf0bc14bbb5d554a75d4f46f1d74795 (patch)
treeb709b913b4d84842e178cfcbdf398e01a93defcb
parent20f48e4b5da6b0ea818a10651900ed62315348e2 (diff)
gnu: Add go-github-com-urfave-cli.
* gnu/packages/golang.scm (go-github-com-urfave-cli): New variable.
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f614c41d67..e07bf6c8e5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3208,3 +3208,29 @@ as conversion to and from @command{net.Addr}.")
(synopsis "Gitignore parser for Go")
(description "A @command{.gitignore} parser for Go.")
(license license:expat))))
+
+(define-public go-github-com-urfave-cli
+ (let ((commit "934abfb2f102315b5794e15ebc7949e4ca253920")
+ (revision "0"))
+ (package
+ (name "go-github-com-urfave-cli")
+ (version (git-version "1.19.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/urfave/cli.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0c5r8pgj3k48dfcwj8lw3cxkwkl8vh0fhvz5snfdwd0bcxdqx1yq"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/urfave/cli"))
+ (home-page "https://github.com/urfave/cli")
+ (synopsis "Simple, fast, and fun package for building command line apps in Go")
+ (description "@command{cli} is a simple, fast, and fun package for
+building command line apps in Go. The goal is to enable developers to write
+fast and distributable command line applications in an expressive way.")
+ (license license:expat))))