summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 11:57:39 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:13:49 +0200
commite53121b36f64bb677127f6814e87e875e0d7ff7b (patch)
tree7d218aa9bdece432a0f0d5bf1a21f195d30a8b03
parent8cb912817363a87ae9d6e3ec858a3f7aa715a913 (diff)
gnu: Add go-github-com-multiformats-go-multiaddr.
* gnu/packages/golang.scm (go-github-com-multiformats-go-multiaddr): New variable.
-rw-r--r--gnu/packages/golang.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ad914d5583..0c5eb6cff1 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3044,3 +3044,45 @@ package cannot cross compile. But 99% of the time the use for
the current user without cgo. This library does that, enabling
cross-compilation.")
(license license:expat))))
+
+(define-public go-github-com-multiformats-go-multiaddr
+ (let ((commit "fe1c46f8be5af4aff4db286e08839295bd922efb")
+ (revision "0"))
+ (package
+ (name "go-github-com-multiformats-go-multiaddr")
+ (version (git-version "1.3.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/multiformats/go-multiaddr.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0p5f8h098a4yjjmzsgqs7vhx1iqifb8izwg3559cr4h7clkpzznh"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path
+ "github.com/multiformats/go-multiaddr"))
+ (native-inputs
+ `(("go-github-com-multiformats-go-multihash" ,go-github-com-multiformats-go-multihash)
+ ("go-github-com-gxed-hashland-keccakpg" ,go-github-com-gxed-hashland-keccakpg)
+ ("go-github-com-minio-blake2b-simd" ,go-github-com-minio-blake2b-simd)
+ ("go-github-com-minio-sha256-simd" ,go-github-com-minio-sha256-simd)
+ ("go-github-com-mr-tron-base58" ,go-github-com-mr-tron-base58)
+ ("go-github-com-spaolacci-murmur3" ,go-github-com-spaolacci-murmur3)
+ ("go-golang-org-x-crypto-union" ,(go-golang-org-x-crypto-union))))
+ (home-page "https://github.com/multiformats/go-multiaddr")
+ (synopsis "Composable and future-proof network addresses")
+ (description "Multiaddr is a standard way to represent addresses that
+does the following:
+
+@itemize
+@item Support any standard network protocols.
+@item Self-describe (include protocols).
+@item Have a binary packed format.
+@item Have a nice string representation.
+@item Encapsulate well.
+@end itemize\n")
+ (license license:expat))))