summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2022-12-24 14:41:29 -0800
committer宋文武 <iyzsong@member.fsf.org>2022-12-30 09:32:48 +0800
commit2fb26d8d8cd1f30d32ccb3e0a870bda5f2a6a43d (patch)
treecb92c9ef5e577d5b4109189425bccfd4f2f8f481
parent00494490f22c9856dbf7b94a1342b2eacb03de1a (diff)
gnu: openshot: Update to 3.0.0.
* gnu/packages/video.scm (libopenshot): Update to 0.3.0. (openshot): Update to 3.0.0. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/video.scm16
1 files changed, 6 insertions, 10 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 41e8ccfb1e..2a70c4496f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -62,6 +62,7 @@
;;; Copyright © 2022 Bird <birdsite@airmail.cc>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;; Copyright © 2022 Chadwain Holness <chadwainholness@gmail.com>
+;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4748,7 +4749,7 @@ create smoother and stable videos.")
(define-public libopenshot
(package
(name "libopenshot")
- (version "0.2.7")
+ (version "0.3.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4757,7 +4758,7 @@ create smoother and stable videos.")
(file-name (git-file-name name version))
(sha256
(base32
- "0i9bsn8gklm1mvj60l3d3xrxdgy8svpxjfqcwsr308j5zjn30pv8"))
+ "0q2899hbaqwh1gxyl9x84l116g82glk0wmr3r1xvfwb107m3mvx9"))
(modules '((guix build utils)))
(snippet '(begin
;; Allow overriding of the python installation dir
@@ -4783,6 +4784,7 @@ create smoother and stable videos.")
libopenshot-audio
qtbase-5
qtmultimedia-5
+ qtsvg-5
zeromq))
(arguments
`(#:configure-flags
@@ -4811,7 +4813,7 @@ API. It includes bindings for Python, Ruby, and other languages.")
(define-public openshot
(package
(name "openshot")
- (version "2.6.1")
+ (version "3.0.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4820,7 +4822,7 @@ API. It includes bindings for Python, Ruby, and other languages.")
(file-name (git-file-name name version))
(sha256
(base32
- "0pa8iwl217503bjlqg2zlrw5lxyq5hvxrf5apxrh3843hj1w1myv"))
+ "1az59whx9sga6m8m2c3ndfls5h07r0jn4jipnyxckpxl32vpd147"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -4857,12 +4859,6 @@ API. It includes bindings for Python, Ruby, and other languages.")
(("fonts") "share/fonts/truetype")
(("[A-Za-z_-]+.ttf") "DejaVuSans.ttf")))
#t))
- ;; https://github.com/OpenShot/openshot-qt/issues/4502
- (add-before 'ensure-no-mtimes-pre-1980 'fix-symbolic-link
- (lambda _
- (delete-file "images/Humanity/actions/custom/razor_line_with_razor.png")
- (symlink "../../../../src/timeline/media/images/razor_line_with_razor.png"
- "images/Humanity/actions/custom/razor_line_with_razor.png")))
(add-before 'install 'set-tmp-home
(lambda _
;; src/classes/info.py "needs" to create several