summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Faiz <adam.faiz@disroot.org>2022-12-18 23:54:22 +0800
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-12-31 08:19:34 +0100
commit6dba52892bced922c30ebfe62debcfd656d26393 (patch)
tree4dd1b8d5c94e09f218ee0c5b88dec7b66d2f976b
parent211524df849f7cbf197455b66a24f4f93b8ad3f9 (diff)
gnu: python-pygame: Use G-Expressions and new-style inputs.
* gnu/packages/game-development.scm (python-pygame)[arguments]: Convert to list of G-Expressions. [inputs]: Drop labels. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/game-development.scm75
1 files changed, 38 insertions, 37 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 07b2c6f3fe..31bc76d4fd 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1203,46 +1203,47 @@ interface (API).")
"0g6j79naab7583kymf1bgxc5l5c9h5laq887rmvh8vw8iyifrl6n"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ; tests require pygame to be installed first
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-build-config
- (lambda _
- (substitute* "buildconfig/config_unix.py"
- (("origincdirs = \\[.*\\]")
- "origincdirs = os.environ['C_INCLUDE_PATH'].split(\":\")")
- (("ORIGLIBDIRS") "LIBRARY_PATH")
- (("incdirs = \\[\\]") "incdirs = origincdirs")
- (("libdirs = \\[\\]") "libdirs = origlibdirs"))))
- (add-after 'unpack 'fix-sdl2-headers
- (lambda _
- (substitute* "buildconfig/config_unix.py"
- (("SDL_ttf.h") "SDL2/SDL_ttf.h")
- (("SDL_image.h") "SDL2/SDL_image.h")
- (("SDL_mixer.h") "SDL2/SDL_mixer.h"))
- (substitute* "src_c/imageext.c"
- (("SDL_image.h") "SDL2/SDL_image.h"))
- (substitute* "src_c/font.h"
- (("SDL_ttf.h") "SDL2/SDL_ttf.h"))
- (substitute* "src_c/mixer.h"
- (("SDL_mixer.h") "SDL2/SDL_mixer.h"))
- (substitute* "src_c/_sdl2/mixer.c"
- (("SDL_mixer.h") "SDL2/SDL_mixer.h")))))))
+ (list
+ #:tests? #f ; tests require pygame to be installed first
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-build-config
+ (lambda _
+ (substitute* "buildconfig/config_unix.py"
+ (("origincdirs = \\[.*\\]")
+ "origincdirs = os.environ['C_INCLUDE_PATH'].split(\":\")")
+ (("ORIGLIBDIRS") "LIBRARY_PATH")
+ (("incdirs = \\[\\]") "incdirs = origincdirs")
+ (("libdirs = \\[\\]") "libdirs = origlibdirs"))))
+ (add-after 'unpack 'fix-sdl2-headers
+ (lambda _
+ (substitute* "buildconfig/config_unix.py"
+ (("SDL_ttf.h") "SDL2/SDL_ttf.h")
+ (("SDL_image.h") "SDL2/SDL_image.h")
+ (("SDL_mixer.h") "SDL2/SDL_mixer.h"))
+ (substitute* "src_c/imageext.c"
+ (("SDL_image.h") "SDL2/SDL_image.h"))
+ (substitute* "src_c/font.h"
+ (("SDL_ttf.h") "SDL2/SDL_ttf.h"))
+ (substitute* "src_c/mixer.h"
+ (("SDL_mixer.h") "SDL2/SDL_mixer.h"))
+ (substitute* "src_c/_sdl2/mixer.c"
+ (("SDL_mixer.h") "SDL2/SDL_mixer.h")))))))
(native-inputs
(list pkg-config))
(inputs
- `(("freetype" ,freetype)
- ("sdl2" ,sdl2)
- ("sdl2-image" ,sdl2-image)
- ("sdl2-mixer" ,sdl2-mixer)
- ("sdl2-ttf" ,sdl2-ttf)
- ("sdl2-gfx" ,sdl2-gfx)
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("libX11" ,libx11)
- ("libsmpeg" ,libsmpeg)
- ("portmidi" ,portmidi)
- ("v4l-utils" ,v4l-utils)))
+ (list freetype
+ sdl2
+ sdl2-image
+ sdl2-mixer
+ sdl2-ttf
+ sdl2-gfx
+ libjpeg-turbo
+ libpng
+ libx11
+ libsmpeg
+ portmidi
+ v4l-utils))
(home-page "https://www.pygame.org")
(synopsis "SDL wrapper for Python")
(description "Pygame is a set of Python modules designed for writing games.