summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-12-25 21:06:18 -0600
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-12-28 10:35:11 +0100
commitacab8e1d47de3ad96645a5b753b41a548c8d6495 (patch)
tree085e6e47964fd24821047bd34039725cd6c038e4
parent4e00a85e200860c099a5259c2b870599d0097497 (diff)
gnu: Add emacs-tempel-collection.
* gnu/packages/emacs-xyz.scm (emacs-tempel-collection): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5d2c302e09..4149ec6d8c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15489,6 +15489,29 @@ been adapted to also work with mu4e.")
the Emacs Tempo library. You may also write your templates in Lisp.")
(license license:gpl3+)))
+(define-public emacs-tempel-collection
+ (let ((commit "cd9529b2a2fdfd49010117d2a1fc49adf9725051")
+ (revision "0"))
+ (package
+ (name "emacs-tempel-collection")
+ (version (git-version "0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Crandel/tempel-collection")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02x6jq5k7fa46ni64qf8wrmkay6zfbmkildb727zs6wchmyg2znn"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-tempel))
+ (home-page "https://github.com/Crandel/tempel-collection")
+ (synopsis "Collection of TempEl templates")
+ (description "This package provides a collection of templates for
+the Emacs TempEl package.")
+ (license license:gpl3+))))
+
(define-public emacs-yasnippet
(package
(name "emacs-yasnippet")