summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-30 15:05:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-30 15:06:12 +0100
commite84f17ea939013f25a0dd1276659e27bc4c2198f (patch)
treee670d865da2ee6c04eef5bec63d5bb356da730c7
parentf7b2108e62cddc344d84a7481fb4704376fe8aa6 (diff)
gnu: Add r-domultibarheatmap.
* gnu/packages/bioinformatics.scm (r-domultibarheatmap): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c2e6b9f320..46febf579a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12710,6 +12710,31 @@ known and yet unknown splice junctions. Circular-to-linear ratios of circRNAs
can be calculated, and a number of descriptive plots easily generated.")
(license license:artistic2.0)))
+(define-public r-domultibarheatmap
+ (let ((commit "9e65afa0aa69fee631c61b7bf3e7742632c9cb95")
+ (revision "1"))
+ (package
+ (name "r-domultibarheatmap")
+ (version (git-version "0.1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elliefewings/DoMultiBarHeatmap")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0q9mrc6md08aff6hhzlw3igvv3w7pr1wildzm8i0km9xvbi9iyy9"))))
+ (properties `((upstream-name . "DoMultiBarHeatmap")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ggplot2 r-magrittr r-rlang r-seurat))
+ (home-page "https://github.com/elliefewings/DoMultiBarHeatmap")
+ (synopsis "Produce heatmap from a Seurat object with multiple annotation bars")
+ (description "This package builds on Seurat's @code{Doheatmap} function
+code to produce a heatmap from a Seurat object with multiple annotation
+bars.")
+ (license license:cc0))))
+
(define-public r-doubletfinder
(let ((commit "554097ba4e2c0ed7c28dc7f0b5b75277f3a50551")
(revision "1"))