summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWiktor Żelazny <wzelazny@vurv.cz>2022-08-25 12:09:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-12-29 23:22:41 +0100
commitf030d0433f1e3dc0b95623022c24e416eaed83c6 (patch)
tree0c598369f434c03c4a7d5f39599075d43f905447
parente830bf71f2f2887e138932aca32650c5b1f44be0 (diff)
gnu: Add r-climatol.
* gnu/packages/cran.scm (r-climatol): New variable.
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 076cf6aa88..2f744fd6d5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1124,6 +1124,28 @@ isolated functions, also called crates, print to the console with their total
size and can be easily tested locally before being sent to a remote.")
(license license:gpl3)))
+(define-public r-climatol
+ (package
+ (name "r-climatol")
+ (version "3.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "climatol" version))
+ (sha256
+ (base32
+ "0p3nk4n7izj0cmmqd9apa1gix5lfdzp08ydy0n7rkl5kbkmrkb6n"))))
+ (properties `((upstream-name . "climatol")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-mapdata r-maps))
+ (home-page "http://www.climatol.eu/")
+ (synopsis "Climate tools")
+ (description
+ "This package provides functions for the quality control, homogenization
+and missing data infilling of climatological series, and to obtain
+climatological summaries and grids from the results. Also functions to draw
+wind-roses and Walter&Lieth climate diagrams are included.")
+ (license license:gpl2+)))
+
(define-public r-clipr
(package
(name "r-clipr")