summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-02 11:47:10 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 14:27:53 +0100
commit10e2fc77a7a44c218b4a829388a93843255727f6 (patch)
tree568223609c0cb57cf87155926aaf6375ea529c20
parenta37f8108dd926b335ed46a3472a3413c0578b2c9 (diff)
gnu: Add kalzium.
* gnu/packages/education.scm (kalzium): New variable.
-rw-r--r--gnu/packages/education.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 80d17b26e9..25898a0b0e 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -32,6 +32,7 @@
#:use-module (gnu packages audio)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
+ #:use-module (gnu packages chemistry)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
@@ -58,6 +59,7 @@
#:use-module (gnu packages mp3)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages ocaml)
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -867,6 +869,62 @@ This package is part of the KDE education module.")
(license ;; GPL for programs, LGPL for libraries, FDL for documentation
(list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+(define-public kalzium
+ (package
+ (name "kalzium")
+ (version "20.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/kalzium-" version ".tar.xz"))
+ (sha256
+ (base32 "1n1ar12zq2maa4dn5yq7m6l3m60n7c98c460mrd6rp7f73kadnsj"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("eigen" ,eigen)
+ ("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(;; TODO: ("avogadrolibs" ,avogadrolibs)
+ ;; TODO: facile
+ ("karchive" ,karchive)
+ ("kcodecs" ,kcodecs)
+ ("kconfig" ,kconfig)
+ ("kcoreaddons" ,kcoreaddons)
+ ("khtml" ,khtml)
+ ("ki18n" ,ki18n)
+ ("kjs" ,kjs)
+ ("kparts" ,kparts)
+ ("kplotting" ,kplotting)
+ ("kunitconversion" ,kunitconversion)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("ocaml" ,ocaml)
+ ("openbabel" ,openbabel)
+ ("oxygen-icons" ,oxygen-icons) ;; default icon set
+ ("qtbase" ,qtbase)
+ ("qtscript" ,qtscript)
+ ("qtsvg" ,qtsvg)
+ ("solid" ,solid)))
+ (home-page "https://kde.org/applications/education/org.kde.kalzium")
+ (synopsis "Periodic table of chemistry elements")
+ (description "Kalzium is a program that shows you the Periodic Table of
+Elements.
+
+You can use Kalzium to search for information about the elements or to learn
+facts about the periodic table. It provides an overview of the important
+data (like melting points, electron affinity, electron negativity, electron
+configuration, radii, mass, ionisation energy), an isotope table, and
+different colored views of the periodic table (separation of the different
+blocks, year simulator, temperature simulator). It contains tools to
+visualize the spectral lines of each element, a molecular weight calculator, a
+3D molecule editor, and an equation solver for stoichiometric problems.
+
+This package is part of the KDE education module.")
+ (license ;; GPL for programs, LGPL for libraries, FDL for documentation
+ (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+
(define-public klavaro
(package
(name "klavaro")