summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-02 20:47:58 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 14:24:47 +0100
commit1bd708c12f73a540e8841dbe531f198f37081b18 (patch)
tree0624de5a450e30e77dbc344846a1e2e339c26504
parentf6904d1f81016de858169f3604b288b76a9baf70 (diff)
gnu: Add analitza.
* gnu/package/education.scm (analitza): New variable.
-rw-r--r--gnu/packages/education.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 360940d87c..e9fcd16e2f 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -77,6 +77,36 @@
#:use-module (guix build-system trivial)
#:use-module (srfi srfi-1))
+(define-public analitza
+ (package
+ (name "analitza")
+ (version "20.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/analitza-" version ".tar.xz"))
+ (sha256
+ (base32 "1qnqqbrjpzndbffjwqlyfqmxxxz04fi3i2g8dx6y8q79z927fzkd"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("eigen" ,eigen)
+ ("extra-cmake-modules" ,extra-cmake-modules)
+ ("qttools" ,qttools)))
+ (inputs
+ `(("oxygen-icons" ,oxygen-icons) ;; default icon set
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtsvg" ,qtsvg)))
+ (home-page "https://invent.kde.org/education/analitza")
+ (synopsis "Library to add mathematical features to your program")
+ (description "This library is used by KAlgebra and may be used by other
+software to parse and work with mathematical expressions.
+
+This package is part of the KDE education module.")
+ (license ;; GPL for programs, LGPL for libraries, FDL for documentation
+ (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+
(define-public artikulate
(package
(name "artikulate")