summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-02 12:25:50 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 14:27:56 +0100
commit215fe6ffead7ced8b2675cfe4d4dc225837da842 (patch)
tree3983140a6edbe6ad00752f284f30cd36d74e459f
parent754537424146977f55b86c71ee5a329ca46ff592 (diff)
gnu: Add kturtle.
* gnu/packages/education.scm (kturtle): New variable.
-rw-r--r--gnu/packages/education.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 9b9b7a4d6c..e027073dfa 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -1727,6 +1727,47 @@ machine, and more.")
mentored learning for programming languages.")
(license license:expat)))
+(define-public kturtle
+ (package
+ (name "kturtle")
+ (version "20.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/kturtle-" version ".tar.xz"))
+ (sha256
+ (base32 "12jr4sbchjpvc730cy4bp2cccdsd8vw901dgyq0nar8p0pvg4ybb"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("knewstuff" ,knewstuff)
+ ("ktextwidgets" ,ktextwidgets)
+ ("oxygen-icons" ,oxygen-icons) ;; default icon set
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)))
+ (home-page "https://kde.org/applications/education/org.kde.kturtle")
+ (synopsis "Educational programming environment")
+ (description "KTurtle aims to make programming as easy and touchable as
+possible, and therefore can be used to teach kids the basics of math, geometry
+and programming.
+
+It provides all programming tools from its user interface. The programming
+language used is TurtleScript, which is loosely based on Logo. All commands
+and messages are translated into the user's language. KTurtle features an
+intuitive syntax highlighting, simple error messages, integrated canvas to
+make drawings, an integrated help, slow-motion and step execution.
+
+This package is part of the KDE education module.")
+ (license ;; GPL for programs, FDL for documentation
+ (list license:gpl2+ license:fdl1.2+))))
+
(define-public libkeduvocdocument
(package
(name "libkeduvocdocument")