summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-02 11:59:56 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 14:27:55 +0100
commit3c2732b94c16e411acb46b44a49f216dd1218394 (patch)
tree07154551e9a4a6259b44f813c97b742035316efd
parenta797e1ebf675359c30cfa64fddf87cf34f6473c4 (diff)
gnu: Add kig.
* gnu/packages/education.scm (kig): New variable.
-rw-r--r--gnu/packages/education.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 4aa48037ce..2d6404cd8a 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -32,6 +32,7 @@
#:use-module (gnu packages audio)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages chemistry)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
@@ -1101,6 +1102,48 @@ This package is part of the KDE education module.")
(license ;; GPL for programs, FDL for documentation
(list license:gpl2+ license:fdl1.2+))))
+(define-public kig
+ (package
+ (name "kig")
+ (version "20.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/kig-" version ".tar.xz"))
+ (sha256
+ (base32 "0ns4rhk822p7jjqy9wnhkbrbais4ih1viw405rl5r5xlqn9bvsiz"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("boost" ,boost)
+ ("karchive" ,karchive)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcrash" ,kcrash)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kparts" ,kparts)
+ ("ktexteditor" ,ktexteditor)
+ ("kxmlgui" ,kxmlgui)
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)
+ ("qtxmlpatterns" ,qtxmlpatterns)))
+ (home-page "https://kde.org/applications/education/org.kde.kig")
+ (synopsis "Interactive geometry tool")
+ (description "Kig is an interactive mathematics software for learning and
+teaching geometry. It allows to explore mathematical figures and concepts
+using the computer and also can serve as a drawing tool for mathematical
+figures. Constructions can be made with points, vectors, lines, and polygons
+and all elements can be modified directly by using the mouse. Kig helps
+teachers and students to make conjectures and to understand how to prove
+geometric theorems.
+
+This package is part of the KDE education module.")
+ (license ;; GPL for programs, FDL for documentation
+ (list license:gpl2+ license:fdl1.2+))))
+
(define-public klavaro
(package
(name "klavaro")