summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-01-10 09:47:38 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-01-10 09:49:13 +0200
commit4a0a4533920c11bf4ddb8c06bee3c2720fa811df (patch)
treed2328fbe6ba3a55345c3f5c8945559598686685a
parent9f829da86fceb78cc6fedfd30ee42071d3e402c4 (diff)
gnu: vim: Skip terminal screen-dump tests.
Even with careful substitutions these tests often break on other architectures anyway. * gnu/packages/vim.scm (vim)[arguments]: Adjust skip-or-fix-failing-tests to skip another terminal screen-dump test.
-rw-r--r--gnu/packages/vim.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index da4404e23c..3e120fac17 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -126,25 +126,13 @@
;; a difference being detected. Patching the expected result is
;; non-trivial due to the special format used, so skip the test.
(substitute* "src/testdir/test_terminal.vim"
+ ((".*Test_open_term_from_cmd.*" line)
+ (string-append line "return\n"))
((".*Test_terminal_postponed_scrollback.*" line)
(string-append line "return\n")))
(substitute* "src/testdir/test_popupwin.vim"
((".*Test_popup_drag_termwin.*" line)
(string-append line "return\n")))
-
- ;; This test compares output against a golden ‘…/|b|i|n|/|s|h…’
- ;; literal. We need to match that and substitute a similarly
- ;; ‘spliced’ path to ‘sh’ in the store, truncated to the last
- ;; 44 (spliced: 88) characters.
- (let ((splice (lambda (s separator)
- (string-join (map string (string->list s))
- separator))))
- (substitute* "src/testdir/dumps/Test_terminal_from_cmd.dump"
- (((splice "/bin/sh" "\\|"))
- (splice (string-take-right (which "sh") 44) "|"))
- ;; Blindly fix some other differences based on error output.
- (("^\\|!") "|<")
- (("@37") "")))
#t))
(add-after 'install 'install-guix.vim
(lambda* (#:key inputs outputs #:allow-other-keys)