summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-12-16 18:58:52 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-08 10:33:10 +0100
commit4c640083f59aa14135c781a9c62a2a144fc42da5 (patch)
tree70af781aaccfde289902fd5ed87f4e8ce65bceeb
parent5fb1ad6e5751ea6b1264ddfd54c385c391745e7e (diff)
gnu: Add rust-crypto-mac-0.10.
* gnu/packages/crates-io.scm (rust-crypto-mac-0.10): New variable. (rust-crypto-mac-0.8) Inherit from rust-crypto-mac-0.10.
-rw-r--r--gnu/packages/crates-io.scm37
1 files changed, 29 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2091ed7d12..30f2657af9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -7588,10 +7588,10 @@ manipulating terminals.")
around common WinAPI calls.")
(license license:expat)))
-(define-public rust-crypto-mac-0.8
+(define-public rust-crypto-mac-0.10
(package
(name "rust-crypto-mac")
- (version "0.8.0")
+ (version "0.10.0")
(source
(origin
(method url-fetch)
@@ -7599,20 +7599,41 @@ around common WinAPI calls.")
(file-name
(string-append name "-" version ".tar.gz"))
(sha256
- (base32
- "1axfs4zmy74rn9666p92j7nmcv11zdp2d51yrppc2dv26cqa715m"))))
+ (base32 "19iyh7h9qaqrv29dhbd31rm6pq023ry78nw7jwr3qjy3l22zsms8"))))
(build-system cargo-build-system)
(arguments
- `(#:cargo-inputs
- (("rust-blobby" ,rust-blobby-0.1)
- ("rust-generic-array" ,rust-generic-array-0.14)
- ("rust-subtle" ,rust-subtle-2))))
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-blobby" ,rust-blobby-0.3)
+ ("rust-cipher" ,rust-cipher-0.2)
+ ("rust-generic-array" ,rust-generic-array-0.14)
+ ("rust-subtle" ,rust-subtle-2))))
(home-page "https://github.com/RustCrypto/traits")
(synopsis "Trait for Message Authentication Code (MAC) algorithms")
(description "This package provides trait for @dfn{Message Authentication
Code} (MAC) algorithms.")
(license (list license:expat license:asl2.0))))
+(define-public rust-crypto-mac-0.8
+ (package
+ (inherit rust-crypto-mac-0.10)
+ (name "rust-crypto-mac")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "crypto-mac" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1rbrq6qy9dl0pj4ym2zy33miaaa8vpzdss60p9bdb58xy46l0d24"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-blobby" ,rust-blobby-0.1)
+ ("rust-generic-array" ,rust-generic-array-0.14)
+ ("rust-subtle" ,rust-subtle-2))))))
+
(define-public rust-crypto-mac-0.7
(package
(inherit rust-crypto-mac-0.8)