summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-02 11:51:45 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 14:27:54 +0100
commit66e2ddb99d76827a8697455c1be7c8bd14ab44bc (patch)
tree3a60558a3aa8b21ad2c9eab890b1e01cb3ed8b0f
parentab05ba38693e1cf0146bc279e4f16551d4d87e0b (diff)
gnu: Add kbruch.
* gnu/packages/education.scm (kbruch): New variable.
-rw-r--r--gnu/packages/education.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 414729eb8e..acaf911570 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -969,6 +969,43 @@ This package is part of the KDE education module")
(license ;; GPL for programs, FDL for documentation
(list license:gpl2+ license:fdl1.2+))))
+(define-public kbruch
+ (package
+ (name "kbruch")
+ (version "20.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/kbruch-" version ".tar.xz"))
+ (sha256
+ (base32 "06sbr6wrn4nh69hq96i5rgzbr9g0rc6c54h9g2zpnpff339lnsqi"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kauth" ,kauth)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("ki18n" ,ki18n)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kxmlgui" ,kxmlgui)
+ ("oxygen-icons" ,oxygen-icons) ;; default icon set
+ ("qtbase" ,qtbase)))
+ (home-page "https://kde.org/applications/education/org.kde.kbruch")
+ (synopsis "Practice calculating with fractions")
+ (description "KBruch is a small program to practice calculating with
+fractions and percentages. Different exercises are provided for this purpose
+and you can use the learning mode to practice with fractions. The program
+checks the user's input and gives feedback.
+
+This package is part of the KDE education module.")
+ (license ;; GPL for programs, FDL for documentation
+ (list license:gpl2+ license:fdl1.2+))))
+
(define-public klavaro
(package
(name "klavaro")