summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-02 12:21:34 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 14:27:56 +0100
commit754537424146977f55b86c71ee5a329ca46ff592 (patch)
tree71a4f8503ae6c9bf7a6081bcb5675f453d5bf370
parentdd5c460e3f9ba1ead4ef009cd1d447b8f2745461 (diff)
gnu: Add kstars.
* gnu/packages/education.scm (kstars): New variable.
-rw-r--r--gnu/packages/education.scm62
1 files changed, 62 insertions, 0 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index f35c7c21ce..9b9b7a4d6c 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -30,6 +30,8 @@
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages audio)
+ #:use-module (gnu packages algebra)
+ #:use-module (gnu packages astronomy)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages boost)
@@ -63,6 +65,7 @@
#:use-module (gnu packages ocaml)
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-web)
@@ -1318,6 +1321,65 @@ This package is part of the KDE education module.")
(license ;; GPL for programs, FDL for documentation
(list license:gpl2+ license:fdl1.2+))))
+(define-public kstars
+ (package
+ (name "kstars")
+ (version "2.9.8") ;; Note: 17.08.3 is older then 2.x
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/Attic/"
+ "kstars/kstars-" version ".tar.xz"))
+ (sha256
+ (base32 "0z9d4c3r1n4i2681zvzs29qa52zaaq5nkkqkbds5skf8djp6rwwm"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("eigen" ,eigen)
+ ("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(;; TODO: ("cfitsio" ,cfitsio) building this backend fails
+ ("kauth" ,kauth)
+ ("kconfig" ,kconfig)
+ ("kcrash" ,kcrash)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("knewstuff" ,knewstuff)
+ ("knotifications" ,knotifications)
+ ("knotifykonfig" ,knotifyconfig)
+ ("kplotting" ,kplotting)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kxmlgui" ,kxmlgui)
+ ("libraw" ,libraw)
+ ("mesa" ,mesa)
+ ("oxygen-icons" ,oxygen-icons) ;; default icon set
+ ("qtbase" ,qtbase)
+ ("qtdatavis3d" ,qtdatavis3d)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtkeychain" ,qtkeychain)
+ ("qtlocation" ,qtlocation)
+ ("qtquickcontrols2" ,qtquickcontrols2)
+ ("qtsvg" ,qtsvg)
+ ("qtwebsockets" ,qtwebsockets)
+ ("wcslib" ,wcslib)
+ ("xplanet" ,xplanet)
+ ("zlib" ,zlib)))
+ ;; TODO: INDI http://www.indilib.org
+ ;; TODO: OpenMP # Needed for LibRaw
+ ;; TODO: AstrometryNet
+ (home-page "https://kde.org/applications/education/org.kde.kstars")
+ (synopsis "Desktop planetarium")
+ (description "KStars provides an accurate graphical simulation of the
+night sky, from any location on Earth, at any date and time. The display
+includes 130,000 stars, 13,000 deep-sky objects, all 8 planets, the Sun and
+Moon, and thousands of comets and asteroids. It includes tools for
+astronomical calculations and can control telescopes and cameras.
+
+This package is part of the KDE education module.")
+ (license ;; GPL for programs, FDL for documentation
+ (list license:gpl2+ license:fdl1.2+))))
+
(define-public ktouch
(package
(name "ktouch")