summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-02 11:42:20 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 14:27:52 +0100
commita37f8108dd926b335ed46a3472a3413c0578b2c9 (patch)
tree82450ffc21576881ecb8aba087a6fdfc8ea7735d
parent4a4ba702a86e96be35e019d9e7873e4b53ed1df6 (diff)
gnu: Add kalgebra.
* gnu/packages/education.scm (kalgebra): New variable.
-rw-r--r--gnu/packages/education.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index ae403bd473..80d17b26e9 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -41,6 +41,7 @@
#:use-module (gnu packages game-development)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages golang)
@@ -825,6 +826,47 @@ For extremely difficult timetables, it may take a longer time, a matter of
hours.")
(license license:agpl3+)))
+(define-public kalgebra
+ (package
+ (name "kalgebra")
+ (version "20.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/kalgebra-" version ".tar.xz"))
+ (sha256
+ (base32 "10y9zygpik418y5781xmy5xysvf3xa97sbzdbch8lrvxwprbmkzm"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("analitza" ,analitza)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("mesa" ,mesa)
+ ("ncurses" ,ncurses)
+ ("oxygen-icons" ,oxygen-icons) ;; default icon set
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtsvg" ,qtsvg)
+ ("qtwebengine" ,qtwebengine)
+ ("readline" ,readline)))
+ (home-page "https://kde.org/applications/education/org.kde.kalgebra")
+ (synopsis "Algebraic graphing calculator")
+ (description "KAlgebra is an application that can replace your graphing
+calculator. It has numerical, logical, symbolic, and analysis features that
+let you calculate mathematical expressions on the console and graphically plot
+the results in 2D or 3D. KAlgebra is rooted in the Mathematical Markup
+Language (MathML); however, one does not need to know MathML to use KAlgebra.
+
+This package is part of the KDE education module.")
+ (license ;; GPL for programs, LGPL for libraries, FDL for documentation
+ (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+
(define-public klavaro
(package
(name "klavaro")