summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-02 11:49:27 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 14:27:53 +0100
commitab05ba38693e1cf0146bc279e4f16551d4d87e0b (patch)
tree47e873762ceba525b78cf55e2927563120108c9e
parenta3b28a85e8a8f0cf22e2474ef7f405ffc52c7e5b (diff)
gnu: Add kanagram.
* gnu/packages/education.scm (kanagram): New variable.
-rw-r--r--gnu/packages/education.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index d28431975d..414729eb8e 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -925,6 +925,50 @@ This package is part of the KDE education module.")
(license ;; GPL for programs, LGPL for libraries, FDL for documentation
(list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+(define-public kanagram
+ (package
+ (name "kanagram")
+ (version "20.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/kanagram-" version ".tar.xz"))
+ (sha256
+ (base32 "0bflybrm3kz1p1n6fksihvd8m0h0jj968b2wjz88663bs48jqf6q"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdeclarative" ,kdeclarative)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("knewstuff" ,knewstuff)
+ ("libkeduvocdocument" ,libkeduvocdocument)
+ ("oxygen-icons" ,oxygen-icons) ;; default icon set
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtspeech" ,qtspeech)
+ ("sonnet" ,sonnet)))
+ (home-page "https://kde.org/applications/education/org.kde.kanagram")
+ (synopsis "Letter order game")
+ (description "Kanagram is a game based on anagrams of words: the puzzle is
+solved when the letters of the scrambled word are put back in the correct
+order. There is no limit on either time taken, or the amount of attempts to
+solve the word. It features several included word lists, a hints-and-cheats
+help system, a word list editor, and allows for updating and distributing
+wordlists via KNewStuff. The interface is scalable and appropriate for
+children.
+
+This package is part of the KDE education module")
+ (license ;; GPL for programs, FDL for documentation
+ (list license:gpl2+ license:fdl1.2+))))
+
(define-public klavaro
(package
(name "klavaro")