summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-02 12:17:58 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 14:27:56 +0100
commitdd5c460e3f9ba1ead4ef009cd1d447b8f2745461 (patch)
treee40488f9cafab273247f4e6ab890679d33cf737c
parent85618078bb08b3a2b4647a40f1ecf42ceff112c3 (diff)
gnu: Add kmplot.
* gnu/packages/education.scm (kmplot): New variable.
-rw-r--r--gnu/packages/education.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 14f4550f1c..f35c7c21ce 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -1272,6 +1272,52 @@ This package is part of the KDE education module.")
(license ;; GPL for programs, LGPL for libraries, FDL for documentation
(list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+(define-public kmplot
+ (package
+ (name "kmplot")
+ (version "20.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/kmplot-" version ".tar.xz"))
+ (sha256
+ (base32 "0iz61jjr7z0j5bh5nqdv9nbdbiz0jhda89bxjds0n9636q42rifm"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("kdelibs4support" ,kdelibs4support)
+ ("kguiaddons" ,kguiaddons)
+ ("ki18n" ,ki18n)
+ ("kparts" ,kparts)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("oxygen-icons" ,oxygen-icons) ;; default icon set
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)))
+ (home-page "https://kde.org/applications/education/org.kde.kmplot")
+ (synopsis "Mathematical function plotter")
+ (description "KmPlot is a powerful mathematical plotter, capable of
+plotting multiple functions simultaneously and combining them into new
+functions.
+
+Cartesian, parametric, and differential functions are supported, as well as
+functions using polar coordinates. Plots are printed with high precision at
+the correct aspect ratio. The graphs can be colorized and the view is
+configurable, is scalable, and can be zoomed.
+
+KmPlot also provides numerical and visual features such as filling and
+calculating the area between the plot and the first axis, finding maxima and
+minima, changing function parameters dynamically, and plotting derivatives
+and integral functions.
+
+This package is part of the KDE education module.")
+ (license ;; GPL for programs, FDL for documentation
+ (list license:gpl2+ license:fdl1.2+))))
+
(define-public ktouch
(package
(name "ktouch")