summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-06-09 13:44:20 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 16:25:53 +0100
commit10a9ded29be00b3284744e543dd725da0b9f718b (patch)
tree7d35aabf1ad3c6469b7e9bb00c1f7df5ded9d8fa
parent01367f1e36b8157e6202683d7fed2e6cd98971cc (diff)
gnu: Add plasma-tests. REWORD
This is intentionally *not* a public variable, since the docs say: "Distributions should not package it, but might want to run it as part of their Plasma builds." * gnu/packages/kde-plasma.scm (plasma-tests): New variable.
-rw-r--r--gnu/packages/kde-plasma.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 762c06103e..497b8badba 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1437,6 +1437,29 @@ development:
@end enumerate")
(license (list license:gpl2 license:gpl2+ license:gpl3+))))
+(define plasma-tests
+ (package
+ (name "plasma-tests")
+ (version "5.19.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/" version
+ "/plasma-tests-" version ".tar.xz"))
+ (sha256
+ (base32 "1ywh4dqzyj96l92v94z6lghkv49davf1d7drvrf1c0lw8j7zvpri"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ ;; TODO: Add input appstreamcli
+ (home-page "https://invent.kde.org/plasma/plasma-tests")
+ (synopsis "Integration-tests for the Plasma workspace")
+ (description "Distributions should not package it, but might want to run
+it as part of their Plasma builds.")
+ ;; No license to be found in the archive. Since most parts of KDE are
+ ;; GPL2+, I assume that here, too.
+ (license license:gpl2+)))
+
(define-public plasma-wayland-protocols
(package
(name "plasma-wayland-protocols")