summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-06-09 13:39:00 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 16:25:52 +0100
commit23abde0bb0d423aef9e080834d9c068e013d7cd7 (patch)
tree6a5e0c02d2ac7e23c78e5e3a3792516c2bc4d555
parent10fd4bacbd0c8966b07aae1060eebf174f4ceaea (diff)
gnu: Add oxygen.
* gnu/packages/kde-plasma.scm (oxygen): New variable.
-rw-r--r--gnu/packages/kde-plasma.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index c0f21a6ca1..15813f8507 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1001,6 +1001,47 @@ does provide application launching. The main difference is that it
concentrates more on searching.")
(license license:gpl3))) ;; KDE e.V.
+(define-public oxygen
+ (package
+ (name "oxygen")
+ (version "5.19.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/" version
+ "/oxygen-" version ".tar.xz"))
+ (sha256
+ (base32 "0d8cvg6h5zf0l4zs6sv7kplfa49n2brs7njwq8znw7c51zdd85s2"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("kde-frameworkintegration" ,kde-frameworkintegration)
+ ("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kiconthemes" ,kiconthemes)
+ ("kguiaddons" ,kguiaddons)
+ ("ki18n" ,ki18n)
+ ("kservice" ,kservice)
+ ("kwayland" ,kwayland)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kwindowsystem" ,kwindowsystem)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("kcmutils" ,kcmutils)
+ ("kdecoration" ,kdecoration)
+ ("qtx11extras" ,qtx11extras)))
+ (home-page "https://invent.kde.org/plasma/oxygen")
+ (synopsis "Widget and icon theme")
+ (description "Plasma and Qt widget style and window decorations for Plasma
+5 and KDE 4.")
+ ;; Parts of the code is Expat licensed, other parts GPL-3+. The artwork is
+ ;; under some different licenses.
+ (license (list license:expat license:lgpl3+ ;; KDE e.V.
+ license:gpl2+ license:lgpl2.1))))
+
(define-public plasma-desktop
(package
(name "plasma-desktop")