summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-06-09 13:34:34 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 16:25:51 +0100
commit249de422e7370d9c91580ae182f91440a76974df (patch)
treef8094a6c38546d3febb4079232a6e7f0b91226d5
parent8e385673537fcb5b574465d83b98b5fdfc508a8a (diff)
gnu: Add kwrited.
* gnu/packages/kde-plasma.scm (kwrited): New variable.
-rw-r--r--gnu/packages/kde-plasma.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index bcb00d1864..e2a9f09f2c 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -786,6 +786,35 @@ and minimize. It also handles placing of windows and switching between
them.")
(license license:gpl2+)))
+(define-public kwrited
+ (package
+ (name "kwrited")
+ (version "5.19.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/" version
+ "/kwrited-" version ".tar.xz"))
+ (sha256
+ (base32 "1nzl5964brxwkhgsadpa94bm985vq3qi75sml1fmgnw1ap4djd69"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("kcoreaddons" ,kcoreaddons)
+ ("kdbusaddons" ,kdbusaddons)
+ ("ki18n" ,ki18n)
+ ("knotifications" ,knotifications)
+ ;; FIXME: kwrited is currently build as an executable, since we don't
+ ;; have utempter yet and thus kpty is build without utempter-support.
+ ("kpty" ,kpty)
+ ("qtbase" ,qtbase)))
+ (home-page "https://invent.kde.org/plasma/kwrited")
+ (synopsis "Read and write console output to X")
+ (description "Kwrited captures console output (e.g. broadcast messages)
+and prints it in a X window.")
+ (license license:gpl2+)))
+
(define-public libkscreen
(package
(name "libkscreen")