summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-27 22:31:57 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 16:25:49 +0100
commit2aad0cf6311af8dc28d3f9322b37b9862a476c64 (patch)
tree92c9453a731db81af6e063e0c62f4320afaffa18
parentcb299fedf3d5c209bb2d8a67493b1a81289b76cc (diff)
gnu: Add kactivitymanagerd.
* gnu/packages/kde-plasma.scm (kactivitymanagerd): New variable.
-rw-r--r--gnu/packages/kde-plasma.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 82d24e4984..51f305eb0b 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -192,6 +192,52 @@ Application Style > GNOME Application Style. Also make sure to disable “apply
colors to non-Qt applications“ in System Settings > Colors > Options.")
(license license:lgpl2.1+)))
+(define-public kactivitymanagerd
+ (package
+ (name "kactivitymanagerd")
+ (version "5.19.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/" version
+ "/kactivitymanagerd-" version ".tar.xz"))
+ (sha256
+ (base32 "1c6394bz0n0qgynhiin9q99xazsj2pn2sfisx6c9pn0jd2cs1hgf"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("boost" ,boost)
+ ("kconfig" ,kconfig)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("kglobalaccel" ,kglobalaccel)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("kwindowsystem", kwindowsystem)
+ ("kxmlgui", kxmlgui)
+ ("qtbase" ,qtbase)))
+ (home-page "https://invent.kde.org/plasma/kactivitymanagerd")
+ (synopsis "System service to manage user's activities, track the usage patterns etc")
+ (description "When a user is interacting with a computer, there are three
+main areas of contextual information that may affect the behaviour of the
+system: who the user is, where they are, and what they are doing.
+
+*Activities* deal with the last one. An activity might be \"developing a KDE
+application\", \"studying 19th century art\", \"composing music\" or
+\"watching funny videos\". Each of these activites may involve multiple
+applications, and a single application may be used in multiple activities (for
+example, most activities are likely to involve using a web browser, but
+different activities will probably involve different websites).
+
+KActivities provides the infrastructure needed to manage a user's activites,
+allowing them to switch between tasks, and for applications to update their
+state to match the user's current activity. This includes a daemon, a library
+for interacting with that daemon, and plugins for integration with other
+frameworks.")
+ (license license:gpl3+)))
+
(define-public kdecoration
(package
(name "kdecoration")