summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-12-12 20:12:31 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 16:25:57 +0100
commit50922b9ec210b8f2338eb36c37b56512f4fc8e82 (patch)
treea012e5388420cd099a6f148e6db996ea3038989f
parent55b341ba61584df91d28d9c60eb59ad7b2c452e2 (diff)
TEMP add helper-scripts
-rwxr-xr-xnext.sh59
-rw-r--r--refresh.sh9
2 files changed, 68 insertions, 0 deletions
diff --git a/next.sh b/next.sh
new file mode 100755
index 0000000000..ea6f343db2
--- /dev/null
+++ b/next.sh
@@ -0,0 +1,59 @@
+#!/usr/bin/env bash
+
+COMMIT=$(head -1 commits.txt | sed 's! .*!!')
+echo commit: $COMMIT
+git cherry-pick $COMMIT
+
+read -p "Konfikte lösen - cherry-pick contine"
+git cherry-pick --continue
+
+SCM=gnu/packages/kde-plasma.scm
+
+NAME=$(git log -p -1 $COMMIT | grep -F '(name "' | tail -1 | sed 's/.*"\(.*\)".*/\1/')
+
+echo name: $NAME
+sed -i 's/build-system cmake-build-system/build-system qt-build-system/' $SCM
+#./pre-inst-env guix refresh -u $NAME
+
+git add gnu/packages/kde-plasma.scm
+git commit --amend --no-edit '-S'
+
+exit
+
+NUMBER=${1?number missing}
+
+patch=$(ls /tmp/plasma-patches/$NUMBER-*.patch)
+#NAME=${patch##*-Add-}
+#NAME=${NAME%*.patch}
+#echo $NUMBER $NAME
+git am $patch
+
+exit
+
+./pre-inst-env guix build refresh -u $NAME
+
+#git gui citool --amend
+
+exit
+
+read -p "Kopieren "
+read -p "Beschreibung "
+read -p "Name in wrapper "
+xdg-open https://cgit.kde.org/$NAME.git/tree/
+read -p "Lizenz "
+
+./pre-inst-env guix refresh -u $NAME
+
+BUILDOKAY=
+while [ -z "$BUILDOKAY" ] ; do
+ ./pre-inst-env guix build --substitute-urls=https://ci.guix.gnu.org $NAME
+ read -p "Build okay? " BUILDOKAY
+done
+
+sh ./00-test-gui-app.sh $NAME &
+sleep 60s
+pgrep -u $(id -u) -f store.*profile.*container.*$NAME | xargs kill
+pgrep -u $(id -u) -f store.*dbus-daemon | xargs kill
+
+git add gnu/packages/games.scm
+git commit -m "gnu: Add $NAME.
diff --git a/refresh.sh b/refresh.sh
new file mode 100644
index 0000000000..8d1fbe969c
--- /dev/null
+++ b/refresh.sh
@@ -0,0 +1,9 @@
+#!/usr/bin/env bash
+
+NAME=$(git log -p -1 HEAD | grep -F '(name "' | tail -1 | sed 's/.*"\(.*\)".*/\1/')
+
+echo name: $NAME
+./pre-inst-env guix refresh -u $NAME
+
+git add gnu/packages/kde-plasma.scm
+git commit --amend --no-edit '-S'