summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-06-09 13:07:35 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 16:25:57 +0100
commit55b341ba61584df91d28d9c60eb59ad7b2c452e2 (patch)
treeecea9b3c6f5cf54c02a87679b6ea73130bd8f54f
parent7b5f25c2cef7fdc76f5fe66d570e3e2fadd326be (diff)
TODO gnu: Add discover.
* gnu/packages/kde-plasma.scm (discover): New variable.
-rw-r--r--gnu/packages/kde-plasma.scm63
1 files changed, 63 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index e0e2c845cc..e9b752f5d0 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -261,6 +261,69 @@ Application Style > GNOME Application Style. Also make sure to disable “apply
colors to non-Qt applications“ in System Settings > Colors > Options.")
(license license:lgpl2.1+)))
+(define-public discover
+ (package
+ (name "discover")
+ (version "5.19.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/" version
+ "/discover-" version ".tar.xz"))
+ (sha256
+ (base32 "10izi9i9q42sjf5fa29dafmscphc9ly6vyi4ciczmfqg8mh9163g"))))
+ (build-system qt-build-system)
+ (arguments
+ `(#:tests? #f ;; FIXME
+ #:validate-runpath? #f ;; FIXME
+ #:configure-flags
+ (let* ((out (assoc-ref %outputs "out"))
+ (lib (assoc-ref %outputs "out"))
+ (libdir (string-append lib "/lib")))
+ (list ;(string-append "-DCMAKE_INSTALL_PREFIX=" out)
+ ;(string-append "-DCMAKE_INSTALL_LIBDIR=" libdir)
+ ;; We need both libdir and libdir/ceph in RUNPATH.
+ (string-append "-DCMAKE_INSTALL_RPATH="
+ libdir ";" libdir "/plasma-discover")
+; (string-append "-DCMAKE_INSTALL_SYSCONFDIR=" out "/etc")
+; (string-append "-DCMAKE_INSTALL_MANDIR=" out "/share/man")
+; (string-append "-DCMAKE_INSTALL_DOCDIR=" out "/share/ceph/doc")
+; (string-append "-DCMAKE_INSTALL_LIBEXECDIR=" out "/libexec")
+; "-DALLOCATOR=jemalloc"
+ ))))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("attica" ,attica)
+ ("karchive" ,karchive)
+ ("kconfig" ,kconfig)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("kdeclarative" ,kdeclarative)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("kitemmodels" ,kitemmodels)
+ ("knewstuff" ,knewstuff)
+ ("knotifications" ,knotifications)
+ ("kxmlgui" ,kxmlgui)
+ ("plasma-framework" ,plasma-framework)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ;; run-time packages
+ ("kirigami", kirigami)
+ ;; optional packages
+ ;;packagekitqt5 http://www.packagekit.org
+ ;;AppStreamQt Library that lists Appstream resources
+))
+ (home-page "https://www.kde.org/plasma-desktop")
+ (synopsis "Application Installer for applications delivered as AppStream packages") ; correct?
+ (description "KDE and Plasma resources management GUI.
+
+This most probably is not of much use in GuixSD for now.")
+ (license (list license:lgpl2.0+ license:gpl3+ license:fdl1.2+))))
+
(define-public kactivitymanagerd
(package
(name "kactivitymanagerd")