summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-06-09 14:02:01 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 16:25:54 +0100
commit5aada6b5fa2fbb9b244d2b6f8968b990bbc5d58a (patch)
treeb17d86b7cfc0ac2bbca70b933211ff585ee531b3
parent9dc52cd32847a8edb5edecac9be8758d403451e5 (diff)
gnu: Add user-manager.
* gnu/packages/kde-plasma.scm (user-manager): New variable.
-rw-r--r--gnu/packages/kde-plasma.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index b63968bd26..eded039ee6 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1775,3 +1775,36 @@ configuring the SDDM Display Manager.")
(description "Plasma System Settings is an improved user interface for
configuring the desktop and other aspects of the system.")
(license license:gpl2+)))
+
+(define-public user-manager
+ (package
+ (name "user-manager")
+ (version "5.19.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/" version
+ "/user-manager-" version ".tar.xz"))
+ (sha256
+ (base32 "1k31lkxd5l37avwr63c4lcmwm0l6l6xifi4qhs07qa7nfljhn9ir"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("kauth" ,kauth)
+ ("kcmutils" ,kcmutils)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kio" ,kio)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("libpwquality" ,libpwquality)
+ ("qtbase" ,qtbase)))
+ (home-page "https://invent.kde.org/plasma/user-manager")
+ (synopsis "User management tool for the Plasma workspace")
+ (description "A simple system settings module to manage the users on your
+system.")
+ (license license:gpl2+)))