summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-30 12:45:57 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 16:25:50 +0100
commit8e385673537fcb5b574465d83b98b5fdfc508a8a (patch)
tree0427434ddaec279e6fb8a6f807033a1d6c0a909b
parentc9e1140c542445de9f19dd3ef123485cca50488f (diff)
gnu: Add kwallet-pam.
* gnu/packages/kde-plasma.scm (kwallet-pam): New variable.
-rw-r--r--gnu/packages/kde-plasma.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 6cf9f34092..bcb00d1864 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -532,6 +532,43 @@ Currently the daemon has been ported to Linux, FreeBSD, Irix,
NetBSD, OpenBSD, Solaris and Tru64 with varying degrees of completion.")
(license (list license:gpl2 license:gpl2+ license:gpl3)))) ;; KDE e.V.
+(define-public kwallet-pam
+ (package
+ (name "kwallet-pam")
+ (version "5.19.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/" version
+ "/kwallet-pam-" version ".tar.xz"))
+ (sha256
+ (base32 "0vwilwji3zvygahbp56h64v508gms2qg5nvh518v70jbcnbyv2kq"))))
+ (build-system qt-build-system)
+ (arguments
+ `(#:tests? #f ;; no make target 'test'
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-socat-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Always install into /lib and not into /lib64.
+ (substitute* "pam_kwallet_init"
+ ((" socat ")
+ (string-append " " (assoc-ref inputs "socat")
+ "/bin/socat ")))
+ #t)))))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("kwallet" ,kwallet)
+ ("libgcrypt" ,libgcrypt)
+ ("pam" ,linux-pam)
+ ("qtbase" ,qtbase)
+ ("socat" ,socat)))
+ (home-page "https://invent.kde.org/plasma/kwallet-pam")
+ (synopsis "PAM module for KWallet")
+ (description "KWallet (KDE Frameworks 5) integration with PAM")
+ (license license:lgpl2.1+)))
+
(define-public kwayland-integration
(package
(name "kwayland-integration")