summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-28 16:26:17 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 16:25:49 +0100
commitc9a8ecef835cb6c8085f9f688ecc7f93ed8ac491 (patch)
tree9fcc4081c11562ed76b82e8d911e795abf40c8f8
parent18145dd26f2f8fe60406aa7764798d7c46875ff9 (diff)
gnu: Add bluedevil.
* gnu/packages/kde-plasma.scm (bluedevil): New variable.
-rw-r--r--gnu/packages/kde-plasma.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 14ee901940..183aa23a14 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -54,6 +54,61 @@
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg))
+(define-public bluedevil
+ (package
+ (name "bluedevil")
+ (version "5.19.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/" version
+ "/bluedevil-" version ".tar.xz"))
+ (sha256
+ (base32 "0bgybz7wppavkfdiibij1nb0wj4v6nl3avsh8jxhhv1x7b3y6mz8"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("bluez-qt" ,bluez-qt)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kdbusaddons" ,kdbusaddons)
+ ("kded" ,kded)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kio" ,kio)
+ ("knotifications" ,knotifications)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kwindowsystem" ,kwindowsystem)
+ ("plasma-framework" ,plasma-framework)
+ ("qtbase" ,qtbase)
+ ;; FIXME: Could NOT find Qt5Qml, Qt5QuickTest
+ ("qtdeclarative" ,qtdeclarative)
+ ("shared-mime-info" ,shared-mime-info)
+ ;; file kservicetypes5/kfileitemaction-plugin.desktop"
+ ;; Required for property type definitions
+ ("kcmutils" ,kcmutils) ;; defines only some of the properties
+ ;; run-time dependencies
+ ("bluez" ,bluez)
+ ("pulseaudio" ,pulseaudio))) ;; more specific: pulseaudio-module-bluetooth
+ (home-page "https://invent.kde.org/plasma/bluedevil")
+ (synopsis "KDE Plasma Bluetooth stack")
+ (description "BlueDevil is a set of components which integrate Bluetooth
+in KDE. It contains:
+@itemize
+@item A KDE Control Module (KCM) to configure all the Bluetooth-related
+ options.
+@item Integration with the KDE input/output system (KIO), which allows you to
+ discover and explore Bluetooth devices from your favorite file browser.
+@item A wizard to pair your devices and connect directly to services they
+ offer, such as input (mouse, keyboard, Wiimote) and audio (headsets,
+ phones).
+@item A system tray application from where all BlueDevil actions can be done
+ (disconnect devices, send files, configure, etc).
+@item A daemon which listens to incoming requests, for example to receive
+ files or to introduce a requested PIN.
+@end itemize")
+ (license license:gpl3))) ;; KDE e.V.
+
(define-public breeze
(package
(name "breeze")