summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-28 23:28:18 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-01-31 16:25:50 +0100
commitd8f77cde871a8226b7c0ee351d9d1349d65704db (patch)
treea12bd2243037d53f824bd519731ea4dba7be49a9
parent2aad0cf6311af8dc28d3f9322b37b9862a476c64 (diff)
gnu: Add kde-cli-tools.
Nether setting XDG_DATA_DIRS nor running after install did make the tests pass. * gnu/packages/kde-plasma.scm (kde-cli-tools): New variable.
-rw-r--r--gnu/packages/kde-plasma.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 51f305eb0b..3def62af23 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -238,6 +238,47 @@ for interacting with that daemon, and plugins for integration with other
frameworks.")
(license license:gpl3+)))
+(define-public kde-cli-tools
+ (package
+ (name "kde-cli-tools")
+ (version "5.19.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/" version
+ "/kde-cli-tools-" version ".tar.xz"))
+ (sha256
+ (base32 "1iw9afdyydng6wcxqy9jf6x9dayskzasmq10252j9d70mqr4hc87"))))
+ (build-system qt-build-system)
+ (arguments
+ `(#:tests? #f)) ; TODO: 1/1 fails – propably due to search-path errors
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kactivities" ,kactivities)
+ ("kcmutils" ,kcmutils)
+ ("kconfig" ,kconfig)
+ ("kdeclarative" ,kdeclarative)
+ ("kdesu" ,kdesu)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kinit" ,kinit)
+ ("kio" ,kio)
+ ("kwindowsystem" ,kwindowsystem)
+ ("plasma-workspace" ,plasma-workspace) ;; FIXME
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtsvg" ,qtsvg)
+ ("qtx11extras" ,qtx11extras)))
+ (home-page "https://invent.kde.org/plasma/kde-cli-tools")
+ (synopsis "Tools to use KDE services from the command line")
+ (description "These command line tools enable you to use KDE services such
+as kioslaves, kdesu, QtSVG, kcontrol modules, KDE trader and start
+applications from the command line.")
+ (license (list license:gpl3+ license:gpl2)))) ;; KDE e.V.
+
(define-public kdecoration
(package
(name "kdecoration")