summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2016-08-13 20:08:02 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-08-13 20:12:07 +1000
commit19c3304072ec69b0fcfe1d792c348713a5f43252 (patch)
tree39862b606e874c8796a80a36b8fb94e8b42014c0
parentce728f70e5ef8783a28652e382c2c9f61c7b4c06 (diff)
gnu: Add xlsx2csv.
* gnu/packages/xml.scm (xlsx2csv): New variable. Signed-off-by: Ben Woodcroft <donttrustben@gmail.com>
-rw-r--r--gnu/packages/xml.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 4bd1c3887d..cfdc6c006d 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
+;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -775,3 +776,35 @@ used to transform, query, validate, and edit XML documents. XPath is used to
match and extract data, and elements can be added, deleted or modified using
XSLT and EXSLT.")
(license license:x11)))
+
+(define-public xlsx2csv
+ (package
+ (name "xlsx2csv")
+ (version "0.7.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/dilshod/"
+ name "/archive/release/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1gpn6kaa7l1ai8c9zx2j3acf04bvxq79pni8jjfjrk01smjbyyql"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2 ; Use python-2 for the test script.
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (substitute* "test/run"
+ ;; Run tests with `python' only
+ (("^(PYTHON_VERSIONS = ).*" all m) (string-append m "['']")))
+ (zero? (system* "test/run")))))))
+ (home-page "https://github.com/dilshod/xlsx2csv")
+ (synopsis "XLSX to CSV converter")
+ (description
+ "Xlsx2csv is a program to convert Microsoft Excel 2007 XML (XLSX and
+XLSM) format spreadsheets into plaintext @dfn{comma separated values} (CSV)
+files. It is designed to be fast and to handle large input files.")
+ (license license:gpl2+)))