summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 20:40:20 +0200
committerDavid Craven <david@craven.ch>2016-08-13 14:07:46 +0200
commit3dbb816a5f8e8d5ddbb04f409adaf4adef4d0d9b (patch)
tree0183ecd037145c005df66303cf66747e15f571ee
parent02613cf54a2aefeb066d05a4090d6f3ed50ff903 (diff)
gnu: kde-frameworks: Add kdnssd.
* gnu/packages/kde-frameworks.scm (kdnssd): New variable. Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
-rw-r--r--gnu/packages/kde-frameworks.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index e9938095a3..217ce8945e 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -423,6 +423,33 @@ as well as an API to create KDED modules.")
;; the lgpl2.1. Some source files are under non-copyleft licenses.
(license license:lgpl2.1+)))
+(define-public kdnssd
+ (package
+ (name "kdnssd")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "01b650g031apxc3vd2m91g2fxqk9l8ap67z6rafniphfwy8i0d5m"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("qttools" ,qttools)))
+ (inputs
+ `(("qtbase" ,qtbase)))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Network service discovery using Zeroconf")
+ (description "KDNSSD is a library for handling the DNS-based Service
+Discovery Protocol (DNS-SD), the layer of Zeroconf that allows network services,
+such as printers, to be discovered without any user intervention or centralized
+infrastructure.")
+ (license license:lgpl2.1+)))
+
(define-public kwindowsystem
(package
(name "kwindowsystem")