summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-03-18 03:44:49 -0400
committerMark H Weaver <mhw@netris.org>2016-08-18 03:29:25 -0400
commit4e2cc3ec569f9828777f489cc38fb332687fd9e7 (patch)
tree0b86e79577f6bb568a3c475016ce7d23bd9ea5ab
parent01b29b4c2549e388d864c44624a2d0a82ea183f5 (diff)
TEMPORARY_HACK: gnu: xfce4-session: On MIPS, remove polkit from inputs.
* gnu/packages/xfce.scm (xfce4-session)[inputs]: Remove polkit when targetting MIPS.
-rw-r--r--gnu/packages/xfce.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 5639f1daa3..93d8f1c631 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015 Sou Bunnbu <iyzsong@gmail.com>
-;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Florian Paul Schmidt <mista.tapas@gmx.net>
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
@@ -490,7 +490,10 @@ your system in categories, so you can quickly find and launch them.")
(inputs
`(("iceauth" ,iceauth)
("upower" ,upower)
- ("polkit" ,polkit)
+ ,@(if (not (string-prefix? "mips" (or (%current-target-system)
+ (%current-system))))
+ `(("polkit" ,polkit))
+ '())
("libsm" ,libsm)
("libwnck" ,libwnck-2)
("libxfce4ui" ,libxfce4ui)))