summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-08-03 13:42:27 +0000
committerLeo Famulari <leo@famulari.name>2016-08-15 14:20:52 -0400
commitcd372ca352553d948a67fc32cf01fc28e39cb5ee (patch)
tree40e6f2c954f41cd32afa7a53bf2a1f3fb91550be
parent5f9d59057458b43609b851dd2f76d9b6fedc8885 (diff)
gnu: libextractor: Add more optional inputs.
* gnu/packages/gnunet.scm (libextractor)[inputs]: Add gtk+, libarchive, libgsf, and libmpeg2. [arguments]: New field. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/gnunet.scm29
1 files changed, 17 insertions, 12 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 0b42c0bc77..788732240c 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -50,6 +50,7 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages video)
#:use-module (gnu packages xiph)
+ #:use-module (gnu packages backup)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
@@ -81,17 +82,12 @@
;; FIXME:
;; The following dependencies are all optional, but should be
;; available for maximum coverage:
- ;; * libarchive
- ;; * libgif (giflib)
- ;; * libgtk+ >= 3.0.0 (may probably drop glib then as a propagated input of
- ;; gtk)
- ;; * libgsf
;; * libmagic (file)
- ;; * libmpeg2
- ;; * libmp4v2
- ;; * librpm
- ;; * libsmf
- ;; * libtidy
+ ;; * libmp4v2 ; package it
+ ;; * librpm ; package it
+ ;; * libsmf ; package it
+ ;; * libtidy ; package it
+ ;; * libgif (giflib) ; investigate failure
(inputs
`(("exiv2" ,exiv2)
("flac" ,flac)
@@ -100,14 +96,23 @@
("glib" ,glib)
("gstreamer" ,gstreamer)
("gst-plugins-base" ,gst-plugins-base)
+ ("gtk+" ,gtk+)
+ ("libarchive" ,libarchive)
+ ("libgsf" ,libgsf)
("libjpeg" ,libjpeg)
+ ("libltdl" ,libltdl)
+ ("libmpeg2" ,libmpeg2)
("libogg" ,libogg)
("libtiff" ,libtiff)
- ("libltdl" ,libltdl)
("libvorbis" ,libvorbis)
("zlib" ,zlib)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--with-ltdl="
+ (assoc-ref %build-inputs "libltdl")))
+ #:parallel-tests? #f))
(synopsis "Library to extract meta-data from media files")
(description
"GNU libextractor is a library for extracting metadata from files. It