summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 20:48:51 +0200
committerDavid Craven <david@craven.ch>2016-08-13 14:07:46 +0200
commitd5348b3fee697e567a3cd073c4347969721396a4 (patch)
tree32defe940859f97e1733ba52b06202e4f98dcd4e
parenta51cdaefbc7a31f3c978629588669aba8bd2c456 (diff)
gnu: kde-frameworks: Add kwayland.
* gnu/packages/kde-frameworks.scm (kwayland): New variable. Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
-rw-r--r--gnu/packages/kde-frameworks.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index ff16f875dd..bd79b5bd5c 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -694,6 +694,44 @@ data being plotted. KPlotWidget automatically converts everything to screen
pixel units.")
(license license:lgpl2.1+)))
+(define-public kwayland
+ (package
+ (name "kwayland")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1h5anbqrxcl1s8kx1l53vcsfr8ifamcjqd47dk8a7lwr1ga6myq2"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("wayland" ,wayland)))
+ (arguments
+ `(#:tests? #f ; FIXME tests require weston to run
+ ; weston requires wayland flags in mesa
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda* _
+ (setenv "XDG_RUNTIME_DIR" "/tmp"))))))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Qt-style API to interact with the wayland client and server")
+ (description "As the names suggest they implement a Client respectively a
+Server API for the Wayland protocol. The API is Qt-styled removing the needs to
+interact with a for a Qt developer uncomfortable low-level C-API. For example
+the callback mechanism from the Wayland API is replaced by signals, data types
+are adjusted to be what a Qt developer expects - two arguments of int are
+represented by a QPoint or a QSize.")
+ (license license:lgpl2.1+)))
+
(define-public kwindowsystem
(package
(name "kwindowsystem")