summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-01-19 07:24:28 +0200
committerMark H Weaver <mhw@netris.org>2016-02-24 11:49:57 -0500
commit0e47b4e7690c1c8dd2d4ec9056215c99653fe40b (patch)
tree1c65ad46d9ce8c98cce1d25181fa4a29c64d20b2
parentfb197c0da4bbfa5015c18f426be632892660cce8 (diff)
gnu: libvpx: Use 'modify-phases'.
* gnu/packages/video.scm (libvpx)[arguments]: Use 'modify-phases'.
-rw-r--r--gnu/packages/video.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 04aca2c084..49ce2e5b99 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -785,20 +785,20 @@ projects while introducing many more.")
"15v7qw0ydyxn08ksb6lxn1l51pxgpwgshdwd3275yrr5hs86fv9h"))))
(build-system gnu-build-system)
(arguments
- `(#:phases (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "CONFIG_SHELL" (which "bash"))
- (let ((out (assoc-ref outputs "out")))
- (setenv "LDFLAGS"
- (string-append "-Wl,-rpath=" out "/lib"))
- (zero? (system* "./configure"
- "--enable-shared"
- "--as=yasm"
- ;; Limit size to avoid CVE-2015-1258
- "--size-limit=16384x16384"
- (string-append "--prefix=" out)))))
- %standard-phases)
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (setenv "CONFIG_SHELL" (which "bash"))
+ (let ((out (assoc-ref outputs "out")))
+ (setenv "LDFLAGS"
+ (string-append "-Wl,-rpath=" out "/lib"))
+ (zero? (system* "./configure"
+ "--enable-shared"
+ "--as=yasm"
+ ;; Limit size to avoid CVE-2015-1258
+ "--size-limit=16384x16384"
+ (string-append "--prefix=" out)))))))
#:tests? #f)) ; no check target
(native-inputs
`(("perl" ,perl)