summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-02-23 12:34:56 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-02-25 12:08:32 -0800
commit215d10f8058d9a7beffd3c852a4c1c0f2f3b6a26 (patch)
treefa531c4b2204c63c8032697144587473e3ee0f4f
parent89dc2e25e61d0b3effe16aaff4af8210fa9e0ba0 (diff)
[wip] Add python-gst
-rw-r--r--gnu/packages/gstreamer.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 45dded1a6e..99d5c4c5fb 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -41,6 +42,7 @@
#:use-module (gnu packages image)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages libffi)
#:use-module (gnu packages mp3)
#:use-module (gnu packages perl)
#:use-module (gnu packages pulseaudio)
@@ -400,3 +402,31 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
"This GStreamer plugin supports a large number of audio and video
compression formats through the use of the libav library.")
(license gpl2+)))
+
+(define-public python-gst
+ (package
+ (name "python-gst")
+ (version "1.6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://gstreamer.freedesktop.org/src/" name "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1w84pmvzki8fza10b6bx5zf1xb3r9x0nrsgfvlisybpx30p37giw"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("python" ,python)
+ ("gstreamer" ,gstreamer)
+ ("libffi" ,libffi)
+ ("gobject-introspection" ,gobject-introspection)))
+ (propagated-inputs
+ `(("python-pygobject" ,python-pygobject)))
+ (home-page "https://gstreamer.freedesktop.org/modules/gst-python.html")
+ (synopsis "GStreamer Python bindings supplement")
+ (description "GStreamer Python overrides for the gobject-introspection-based
+pygst bindings.")
+ (license lgpl2.0+)))