summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-02-14 15:57:24 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-02-21 19:01:16 -0800
commit22df6419f86929f34be561e958136950759710a6 (patch)
treec825ebae6493a04931f1af9d6cac613fdb2e6210
parentb6f0b9fb68bd85e662698ddf8a066075f3cd8e9a (diff)
gnu: Add python-celery.
* gnu/packages/python.scm (python-celery, python2-celery): New variables.
-rw-r--r--gnu/packages/python.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 869ce29689..81b4248963 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8008,3 +8008,42 @@ Python 2.4 and 2.5, and will draw its fixes/improvements from python-trunk.")
("python2-unittest2" ,python2-unittest2)
("python2-mock" ,python2-mock)
,@(package-native-inputs billiard))))))
+
+(define-public python-celery
+ (package
+ (name "python-celery")
+ (version "3.1.20")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "celery" version))
+ (sha256
+ (base32
+ "1md6ywg1s0946qyp8ndnsd677wm0yax933h2sb4m3a4j7lf1jbyh"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (propagated-inputs
+ `(("python-pytz" ,python-pytz)
+ ("python-billiard" ,python-billiard)
+ ("python-kombu" ,python-kombu)))
+ (home-page "http://celeryproject.org")
+ (synopsis "Distributed Task Queue")
+ (description "Celery is an asynchronous task queue/job queue based on
+distributed message passing. It is focused on real-time operation, but
+supports scheduling as well. The execution units, called tasks, are executed
+concurrently on a single or more worker servers using multiprocessing,
+Eventlet, or gevent. Tasks can execute asynchronously (in the background) or
+synchronously (wait until ready).")
+ (license bsd-3)
+ (properties `((python2-variant . ,(delay python2-celery))))))
+
+(define-public python2-celery
+ (let ((celery (package-with-python2
+ (strip-python2-variant python-celery))))
+ (package
+ (inherit celery)
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)
+ ("python2-unittest2" ,python2-unittest2)
+ ("python2-mock" ,python2-mock)
+ ,@(package-native-inputs celery))))))