summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Wingo <wingo@igalia.com>2016-02-18 20:58:18 +0100
committerMark H Weaver <mhw@netris.org>2016-02-24 11:49:57 -0500
commit34efce4ff44722f9ccd91d35f3c215a852451df1 (patch)
tree45949fc16862ccea1ba24665259e2bfb13314e9b
parentffc959939f06a66f00f1125ea2ca1e61ceb9ce53 (diff)
gnu: libwacom: Propagate glib input.
* gnu/packages/xdisorg.scm (libwacom): Propagate glib input.
-rw-r--r--gnu/packages/xdisorg.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 46fccfebbe..f01e17a23f 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -626,19 +626,21 @@ Escape key when Left Control is pressed and released on its own.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("glib" ,glib)
- ("gtk+" ,gtk+)
+ `(("gtk+" ,gtk+)
("libgudev" ,libgudev)
("eudev" ,eudev)
("libxml2" ,libxml2)))
+ (propagated-inputs
+ ;; libwacom includes header files that include GLib, and libinput uses
+ ;; those header files.
+ `(("glib" ,glib)))
(home-page "http://linuxwacom.sourceforge.net/")
(synopsis "Helper library for Wacom tablet settings")
(description
- "Libwacom is a library to help implement Wacom tablet settings. It
-is intended to be used by client-programs that need model identification. It
-is already being used by the gnome-settings-daemon and the GNOME 3.4 Control
-Center Wacom tablet applet. In the future, the xf86-input-wacom driver may
-use it as well.")
+ "Libwacom is a library to help implement Wacom tablet settings. It is
+intended to be used by client-programs that need model identification. It is
+already being used by the gnome-settings-daemon and the GNOME Control Center
+Wacom tablet applet.")
(license license:x11)))
(define-public xf86-input-wacom