summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-02-24 14:34:29 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-02-24 20:25:25 +0200
commitc73210d7a9965e489b3280e24e16a56a07f9402c (patch)
treea9ab2ad2fd21c36fb3bd873646426f17f9763767
parent6d415db23d5934a6b367845c5a1a21687012b6f3 (diff)
gnu: kde-frameworks: Update to 5.19.0.
* gnu/packages/kde-frameworks.scm (kwindowsystem): Update to 5.19.0. (extra-cmake-modules): Update to 5.19.0.
-rw-r--r--gnu/packages/kde-frameworks.scm23
1 files changed, 13 insertions, 10 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 5e73a6b7fa..ec637e55d1 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,7 +27,7 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages xorg))
-(define kde-frameworks-version "5.12.0")
+(define kde-frameworks-version "5.19.0")
(define-public extra-cmake-modules
(package
@@ -39,7 +40,8 @@
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "14n77sn493m8kzr42wv13mdgxpnbx7x64bvw37ircrx8wmf4002i"))))
+ (base32
+ "1dl3hhbara7iswb5wsc5dp17ar3ljw5f0nrncl8vry9smaz2zl63"))))
;; The package looks for Qt5LinguistTools provided by Qt, but apparently
;; compiles without it; it might be needed for building the
;; documentation, which requires the additional Sphinx package.
@@ -63,18 +65,19 @@ common build settings used in software produced by the KDE community.")
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "0fjxhf07r186cmp0mjvinrwxg4z90zlyvycqhy0n18fdp67szckl"))))
+ (base32
+ "115xs34r74j9zcsw69glnh8w59iyh764n3gniawwrk23c6yb8fch"))))
(build-system cmake-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("xorg-server" ,xorg-server))) ; for the tests
+ `(("pkg-config" ,pkg-config)
+ ("xorg-server" ,xorg-server))) ; for the tests
(inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("libxrender" ,libxrender)
- ("qt" ,qt)
- ("xcb-utils-keysyms" ,xcb-util-keysyms)))
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("libxrender" ,libxrender)
+ ("qt" ,qt)
+ ("xcb-utils-keysyms" ,xcb-util-keysyms)))
(arguments
- `(#:tests? #f)) ; FIXME: The first seven tests fail with "Exception".
+ `(#:tests? #f)) ; FIXME: The first seven tests fail with "Exception".
(home-page "https://community.kde.org/Frameworks")
(synopsis "KDE access to the windowing system")
(description "KWindowSystem provides information about and allows