summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-07 21:42:17 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-07 21:54:50 +0200
commit00ef6c18d5c6b22874221e9be74f3ba0641c0034 (patch)
tree47c18b42bbc8586e944241539f3cc231adcb21d4
parent0169aee33e154c1fa8b299c7f126f3e94a8dc9a4 (diff)
gnu: giac: Fix build.
* gnu/packages/algebra.scm (giac)[source]<origin>: Add a patch to fix build issue with Pari-GP 2.15. [arguments]<#:phase>: Skip another test. * gnu/packages/patches/giac-pari-gp-anyarg.patch: New file. * gnu/local.mk: Register it. This fixes <https://issues.guix.gnu.org/58274>.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/algebra.scm10
-rw-r--r--gnu/packages/patches/giac-pari-gp-anyarg.patch28
3 files changed, 37 insertions, 2 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 698070c639..a013647d7e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1187,6 +1187,7 @@ dist_patch_DATA = \
%D%/packages/patches/ghostscript-no-header-id.patch \
%D%/packages/patches/ghostscript-no-header-uuid.patch \
%D%/packages/patches/ghostscript-no-header-creationdate.patch \
+ %D%/packages/patches/giac-pari-gp-anyarg.patch \
%D%/packages/patches/giara-fix-login.patch \
%D%/packages/patches/glib-appinfo-watch.patch \
%D%/packages/patches/glib-networking-gnutls-binding.patch \
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index f94aba1ebf..d4b7810308 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -339,7 +339,12 @@ precision.")
"~parisse/debian/dists/stable/main/source/"
"giac_" version ".tar.gz"))
(sha256
- (base32 "1zh7bf0ag4vbyyj5n8lbvy2ivp0kshms40ra5lq1ff035rpx230j"))))
+ (base32 "1zh7bf0ag4vbyyj5n8lbvy2ivp0kshms40ra5lq1ff035rpx230j"))
+ (patches
+ ;; Patch borrowed from Sage math team. Giac 1.9.0-21 does not build
+ ;; since Pari-GP 2.15 upgrade. Reported upstream here:
+ ;; <https://xcas.univ-grenoble-alpes.fr/forum/viewtopic.php?f=3&t=2800>.
+ (search-patches "giac-pari-gp-anyarg.patch"))))
(build-system gnu-build-system)
(arguments
(list
@@ -355,9 +360,10 @@ precision.")
(find-files "doc" "^Makefile"))
(("/bin/cp") (which "cp")))))
(add-after 'unpack 'disable-failing-test
- ;; FIXME: Test failing. Not sure why.
+ ;; FIXME: Tests failing. Not sure why.
(lambda _
(substitute* "check/Makefile.in"
+ (("chk_fhan4") "")
(("chk_fhan11") ""))))
(add-after 'install 'fix-doc
(lambda _
diff --git a/gnu/packages/patches/giac-pari-gp-anyarg.patch b/gnu/packages/patches/giac-pari-gp-anyarg.patch
new file mode 100644
index 0000000000..0441f6bcf9
--- /dev/null
+++ b/gnu/packages/patches/giac-pari-gp-anyarg.patch
@@ -0,0 +1,28 @@
+From 041d16b521d8231e5b441015f08bb386f9d2a51c Mon Sep 17 00:00:00 2001
+From: Vincent Delecroix <20100.delecroix@gmail.com*>
+Date: Thu, 15 Sep 2022 12:11:01 +0200
+Subject: ANYARG giac patch
+
+---
+diff --git a/src/pari.cc b/src/pari.cc
+index 76ce8e1..50d08ab 100644
+--- a/src/pari.cc
++++ b/src/pari.cc
+@@ -40,6 +40,13 @@ using namespace std;
+
+ #ifdef HAVE_LIBPARI
+
++// Anyarg disappeared from PARI 2.15.0
++#ifdef __cplusplus
++# define ANYARG ...
++#else
++# define ANYARG
++#endif
++
+ #ifdef HAVE_PTHREAD_H
+ #include <pthread.h>
+ #endif
+
+--
+cgit v1.0-1-gd88e
+