summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-11-24 11:24:37 +0000
committerChristopher Baines <mail@cbaines.net>2022-11-25 10:51:52 +0000
commit3271fa1f402e497ff1de9cc2dbc2b09e1a32078f (patch)
treef620952268361aafe95223b6e21388e89bbe0bd2
parent6827d76d383be2a0ef655767fb1420cf641f9790 (diff)
gnu: Add python-drms.
* gnu/packages/astronomy.scm (python-drms): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/astronomy.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index d450d1dd94..fb45a83b34 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1142,6 +1142,43 @@ attempting to maintain ISTP compliance
@end itemize")
(license license:expat)))
+(define-public python-drms
+ (package
+ (name "python-drms")
+ (version "0.6.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "drms" version))
+ (sha256
+ (base32 "1b0w350y4wbgyy19zcf28xbb85mqq6gnhb6ppibbc4hbn2ixbcvj"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests?
+ #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (setenv "JSOC_EMAIL" "jsoc@sunpy.org")
+ (invoke "python" "-m" "pytest" "-vv")))))))
+ (native-inputs
+ (list python-astropy
+ python-pytest-astropy
+ python-pytest
+ python-setuptools-scm))
+ (propagated-inputs (list python-numpy python-pandas))
+ (home-page "https://sunpy.org")
+ (synopsis "Access astronomical HMI, AIA and MDI data with Python")
+ (description
+ "DRMS module provides an easy-to-use interface for accessing HMI, AIA and
+MDI data with Python. It uses the publicly accessible
+JSOC (@url{http://jsoc.stanford.edu/}) DRMS server by default, but can also be
+used with local NetDRMS sites.")
+ (license license:bsd-2)))
+
(define-public python-ephem
(package
(name "python-ephem")