summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-22 17:24:16 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-11 21:57:45 +0200
commit3b08d1a6126e0d07fc4ee35220693491402c5cf9 (patch)
treeaec1b27cb1c1111fa2e88c02426c88bee76c1e8e
parent5f25fd69df4f9f2a507fb1d122d56a1f674b852f (diff)
gnu: Add python-mysqlclient.
* gnu/packages/python.scm (python-mysqlclient, python2-mysqlclient): New variables.
-rw-r--r--gnu/packages/python.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 916b00565d..503e653644 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14533,3 +14533,38 @@ several utilities, as well as an API for building localization tools.")
(define-public python2-translate-toolkit
(package-with-python2 python-translate-toolkit))
+
+(define-public python-mysqlclient
+ (package
+ (name "python-mysqlclient")
+ (version "1.3.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mysqlclient" version))
+ (sha256
+ (base32
+ "0qkj570x4rbsblji6frvsvp2v1ap32dqzj1lq62zp9515ffsyaj5"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("mariadb" ,mariadb)
+ ("nose" ,python-nose)
+ ("mock" ,python-mock)
+ ("py.test" ,python-pytest)))
+ (inputs
+ `(("mysql" ,mysql)
+ ("libz" ,zlib)
+ ("openssl" ,openssl)))
+ (home-page "https://github.com/PyMySQL/mysqlclient-python")
+ (synopsis "MySQLdb is an interface to the popular MySQL database server for Python")
+ (description "MySQLdb is an interface to the popular MySQL database server
+for Python. The design goals are:
+@enumerate
+@item Compliance with Python database API version 2.0 [PEP-0249],
+@item Thread-safety,
+@item Thread-friendliness (threads will not block each other).
+@end enumerate")
+ (license license:gpl2)))
+
+(define-public python2-mysqlclient
+ (package-with-python2 python-mysqlclient))