summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorconses <contact@conses.eu>2022-11-24 17:21:26 +0100
committerChristopher Baines <mail@cbaines.net>2022-11-25 10:51:52 +0000
commit6827d76d383be2a0ef655767fb1420cf641f9790 (patch)
tree203a7b0550afcb91a2d2fc79475e15a4cfb0c41c
parent123e6f5f2422f573673a5fdce88d88014bcbe0f1 (diff)
gnu: Add portfolio.
* gnu/packages/gnome-xyz.scm (portfolio): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/gnome-xyz.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index b7e10100fb..0368ccc223 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -55,6 +55,7 @@
#:use-module (gnu packages bash)
#:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -304,6 +305,59 @@ and products. Plots is designed to integrate well with the GNOME desktop and
takes advantage of modern hardware using OpenGL.")
(license license:gpl3+)))
+(define-public portfolio
+ (package
+ (name "portfolio")
+ (version "0.9.14")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tchx84/Portfolio")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0h09v8lhz3kv6qmwjhx3gr7rp6ccfhrzm54gjnaixl4dcg9zddls"))))
+ (arguments
+ (list #:glib-or-gtk? #t
+ #:imported-modules `(,@%meson-build-system-modules
+ (guix build python-build-system))
+ #:modules '((guix build meson-build-system)
+ ((guix build python-build-system)
+ #:prefix python:)
+ (guix build utils))
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'rename-executable
+ (lambda _
+ (with-directory-excursion (string-append #$output
+ "/bin")
+ (symlink "dev.tchx84.Portfolio" "portfolio"))))
+ (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (search-input-file outputs
+ "bin/dev.tchx84.Portfolio")
+ `("GUIX_PYTHONPATH" =
+ (,(getenv "GUIX_PYTHONPATH") ,(python:site-packages
+ inputs
+ outputs)))
+ `("GI_TYPELIB_PATH" =
+ (,(getenv "GI_TYPELIB_PATH")))))))))
+ (build-system meson-build-system)
+ (inputs (list bash-minimal python-pygobject gtk+ libhandy))
+ (native-inputs
+ (list desktop-file-utils
+ gettext-minimal
+ `(,glib "bin")
+ `(,gtk+ "bin")
+ python))
+ (home-page "https://github.com/tchx84/Portfolio")
+ (synopsis "Minimalist file manager for Linux mobile devices")
+ (description
+ "Portfolio is a minimalist file manager for those who want to use Linux
+mobile devices. Tap to activate and long press to select, to browse, open,
+copy, move, delete, or edit your files.")
+ (license license:gpl3+)))
+
(define-public gnome-shell-extension-unite-shell
(package
(name "gnome-shell-extension-unite-shell")