summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-17 23:28:45 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-23 23:56:15 -0400
commit84369105d4fc8c6f9399e6157112259deada30b8 (patch)
treedd28744f672ad0f6f5c8fe07b117b95e6c50340b
parent503cfd542124d5e6983c28839953424e44b88244 (diff)
gnu: jami: Update to 20220825.0828.c10f01f.
* gnu/packages/jami.scm (jami): Update to 20220825.0828.c10f01f. (%jami-version): Set to latest release. (%jami-sources): Remove jami-fix-esc-bug.patch; add jami-fix-crash-on-block-contact.patch. * gnu/packages/patches/jami-fix-esc-bug.patch: Delete file. * gnu/packages/patches/jami-fix-crash-on-block-contact.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
-rw-r--r--gnu/local.mk8
-rw-r--r--gnu/packages/jami.scm6
-rw-r--r--gnu/packages/patches/jami-fix-crash-on-block-contact.patch32
-rw-r--r--gnu/packages/patches/jami-fix-esc-bug.patch24
4 files changed, 39 insertions, 31 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index b3cf87de97..d99c650d1a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1325,10 +1325,7 @@ dist_patch_DATA = \
%D%/packages/patches/irrlicht-link-against-needed-libs.patch \
%D%/packages/patches/isl-0.11.1-aarch64-support.patch \
%D%/packages/patches/itk-snap-alt-glibc-compat.patch \
- %D%/packages/patches/jami-fix-esc-bug.patch \
- %D%/packages/patches/json-c-0.13-CVE-2020-12762.patch \
- %D%/packages/patches/json-c-0.12-CVE-2020-12762.patch \
- %D%/packages/patches/jsoncpp-pkg-config-version.patch \
+ %D%/packages/patches/jami-fix-crash-on-block-contact.patch \
%D%/packages/patches/jamvm-1.5.1-aarch64-support.patch \
%D%/packages/patches/jamvm-1.5.1-armv7-support.patch \
%D%/packages/patches/jamvm-2.0.0-aarch64-support.patch \
@@ -1350,6 +1347,9 @@ dist_patch_DATA = \
%D%/packages/patches/jfsutils-add-sysmacros.patch \
%D%/packages/patches/jfsutils-gcc-compat.patch \
%D%/packages/patches/jfsutils-include-systypes.patch \
+ %D%/packages/patches/json-c-0.13-CVE-2020-12762.patch \
+ %D%/packages/patches/json-c-0.12-CVE-2020-12762.patch \
+ %D%/packages/patches/jsoncpp-pkg-config-version.patch \
%D%/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch \
%D%/packages/patches/julia-tracker-16-compat.patch \
%D%/packages/patches/julia-allow-parallel-build.patch \
diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index 95c0052841..26081910ff 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -66,7 +66,7 @@
#:use-module (guix packages)
#:use-module (guix utils))
-(define %jami-version "20220726.1515.da8d1da")
+(define %jami-version "20220825.0828.c10f01f")
(define %jami-sources
;; Return an origin object of the tarball release sources archive of the
@@ -90,8 +90,8 @@
"plugins"))))
(sha256
(base32
- "1zx0i9aw8jsba3bjc5r4pkkybm8c0lyz420ciq89vsswd48gfdhg"))
- (patches (search-patches "jami-fix-esc-bug.patch"))))
+ "1iv06jb66g206qxm75v7rc3mqvrml1028avflsj11chj8jh63j14"))
+ (patches (search-patches "jami-fix-crash-on-block-contact.patch"))))
;; Jami maintains a set of patches for some key dependencies (currently
;; pjproject and ffmpeg) of Jami that haven't yet been integrated upstream.
diff --git a/gnu/packages/patches/jami-fix-crash-on-block-contact.patch b/gnu/packages/patches/jami-fix-crash-on-block-contact.patch
new file mode 100644
index 0000000000..60dab79296
--- /dev/null
+++ b/gnu/packages/patches/jami-fix-crash-on-block-contact.patch
@@ -0,0 +1,32 @@
+From 673dc5f525c9d478fc22f8ea0a50d9849a81f6c8 Mon Sep 17 00:00:00 2001
+From: Kateryna Kostiuk <kateryna.kostiuk@savoirfairelinux.com>
+Date: Fri, 2 Sep 2022 13:32:10 -0400
+Subject: [PATCH] conversation: fix crash when block contact
+
+This patch fixes crash that happened when block contact
+for not active account.
+
+GitLab: #758
+Change-Id: I5347394a67cdffe0d95c9ee03aedf9d2618cec55
+---
+ src/jamidht/jamiaccount.cpp | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/daemon/src/jamidht/jamiaccount.cpp b/daemon/src/jamidht/jamiaccount.cpp
+index fe15eedb2..9d0a5ee68 100644
+--- a/daemon/src/jamidht/jamiaccount.cpp
++++ b/daemon/src/jamidht/jamiaccount.cpp
+@@ -1129,7 +1129,9 @@ JamiAccount::loadAccount(const std::string& archive_password,
+ if (auto convModule = shared->convModule())
+ convModule->removeContact(uri, banned);
+ // Remove current connections with contact
+- shared->connectionManager_->closeConnectionsWith(uri);
++ if (shared->connectionManager_) {
++ shared->connectionManager_->closeConnectionsWith(uri);
++ }
+ // Update client.
+ emitSignal<DRing::ConfigurationSignal::ContactRemoved>(shared->getAccountID(),
+ uri,
+--
+2.37.3
+
diff --git a/gnu/packages/patches/jami-fix-esc-bug.patch b/gnu/packages/patches/jami-fix-esc-bug.patch
deleted file mode 100644
index 6d78542f1e..0000000000
--- a/gnu/packages/patches/jami-fix-esc-bug.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-This fixes the issue where pressing the ESC key would hide the Jami
-GUI on systems lacking a notification tray.
-
-From 47fd4c38ddd8bd350319ce9bb750ca496826e655 Mon Sep 17 00:00:00 2001
-From: Sébastien Blin <sebastien.blin@savoirfairelinux.com>
-Date: Fri, 29 Jul 2022 21:24:01 -0400
-Subject: [PATCH] layoutmanager: fix popFullScreenItem
-
-Change-Id: I79780d4ad570846e6f3c52734dd627bcd0e11327
----
-
-diff --git a/src/app/LayoutManager.qml b/src/app/LayoutManager.qml
-index 98516ce..87f13ac 100644
---- a/client-qt/src/app/LayoutManager.qml
-+++ b/client-qt/src/app/LayoutManager.qml
-@@ -176,7 +176,7 @@
-
- // Only leave fullscreen mode if our window isn't in fullscreen
- // mode already.
-- if (priv.fullScreenItems.length === 0) {
-+ if (priv.fullScreenItems.length === 0 && priv.windowedVisibility !== Window.Hidden) {
- // Simply recall the last visibility state.
- visibility = priv.windowedVisibility
- }