summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-22 19:11:48 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-11 21:58:07 +0200
commitc009e934512acf82aa2e3a7bda7765039afe4d9a (patch)
tree063ff4f2cd894e8fc45d1889e0aaf6545da95bca
parent932462536bfe9947eee205514ee52f1b05165f2b (diff)
gnu: Add python-hiredis.
* gnu/packages/python.scm (python-hiredis, python2-hiredis): New variables.
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 503e653644..bee94b42e2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14568,3 +14568,27 @@ for Python. The design goals are:
(define-public python2-mysqlclient
(package-with-python2 python-mysqlclient))
+
+(define-public python-hiredis
+ (package
+ (name "python-hiredis")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "hiredis" version))
+ (sha256
+ (base32
+ "1dfm2k9l9zar9nw9fwmm74zrgraxdxs04vx9li56fjcf289qx5fa"))))
+ (build-system python-build-system)
+ (arguments
+ ;; no tests
+ `(#:tests? #f))
+ (home-page "https://github.com/redis/hiredis-py")
+ (synopsis "Python extension that wraps protocol parsing code in hiredis")
+ (description "Python-hiredis is a python extension that wraps protocol
+parsing code in hiredis. It primarily speeds up parsing of multi bulk replies.")
+ (license license:bsd-3)))
+
+(define-public python2-hiredis
+ (package-with-python2 python-hiredis))