summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHendursaga <hendursaga@aol.com>2022-09-04 11:31:29 -0400
committerAndreas Enge <andreas@enge.fr>2022-09-12 17:35:35 +0200
commitf3130fc7d9cbfe13b7deb637c6bd9b666d0f1330 (patch)
tree4a87027f811e1cc835958e8982d1b327b74d5bb9
parent25d88eb9f3e22816180c099502a3a919bbe602f6 (diff)
gnu: cmh: Update to 1.1.1.
* gnu/packages/algebra.scm (cmh): Update to 1.1.1. * gnu/packages/patches/cmh-support-fplll.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/algebra.scm47
-rw-r--r--gnu/packages/patches/cmh-support-fplll.patch27
3 files changed, 23 insertions, 52 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 19102113c9..02aa555541 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -975,7 +975,6 @@ dist_patch_DATA = \
%D%/packages/patches/cling-use-shared-library.patch \
%D%/packages/patches/clucene-pkgconfig.patch \
%D%/packages/patches/cmake-curl-certificates.patch \
- %D%/packages/patches/cmh-support-fplll.patch \
%D%/packages/patches/coda-use-system-libs.patch \
%D%/packages/patches/collectd-5.11.0-noinstallvar.patch \
%D%/packages/patches/containerd-create-pid-file.patch \
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index e5bd12eeb8..87fcca746b 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -294,34 +294,33 @@ GP2C, the GP to C compiler, translates GP scripts to PARI programs.")
(define-public cmh
(package
- (name "cmh")
- (version "1.1.0")
- (source (origin
- (method url-fetch)
- ;; Git repo at <https://gitlab.inria.fr/cmh/cmh>.
- (uri (string-append "http://www.multiprecision.org/downloads/cmh-"
- version ".tar.gz"))
- (sha256
- (base32
- "1ws2yhzxmm2l5xqqqcjcimmg40f9qq5l9i6d4i5434an9v9s8531"))
- (patches (search-patches "cmh-support-fplll.patch"))))
- (build-system gnu-build-system)
- (inputs
- (list gmp
- mpfr
- mpc
- mpfrcx
- fplll
- pari-gp))
- (synopsis "Igusa class polynomial computations")
- (description
- "The CMH software computes Igusa (genus 2) class polynomials, which
+ (name "cmh")
+ (version "1.1.1")
+ (source (origin
+ (method url-fetch)
+ ;; Git repo at <https://gitlab.inria.fr/cmh/cmh>.
+ (uri (string-append
+ "https://www.multiprecision.org/downloads/cmh-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0nadvqfmidgks1s7aljsf8dp32pz7vjaxyaym36m9bx4zr8msk91"))))
+ (build-system gnu-build-system)
+ (inputs (list gmp
+ mpfr
+ mpc
+ mpfrcx
+ fplll
+ pari-gp))
+ (synopsis "Igusa class polynomial computations")
+ (description
+ "The CMH software computes Igusa (genus 2) class polynomials, which
parameterize the CM points in the moduli space of 2-dimensional abelian
varieties, i.e. Jacobians of hyperelliptic curves.
It can also be used to compute theta constants at arbitrary
precision.")
- (license license:gpl3+)
- (home-page "http://www.multiprecision.org/cmh/home.html")))
+ (license license:gpl3+)
+ (home-page "https://www.multiprecision.org/cmh/home.html")))
(define-public giac
(package
diff --git a/gnu/packages/patches/cmh-support-fplll.patch b/gnu/packages/patches/cmh-support-fplll.patch
deleted file mode 100644
index fae04f456b..0000000000
--- a/gnu/packages/patches/cmh-support-fplll.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Patch from the CMH git, after the 1.1.0 release.
-
-From 2328c819317dda2171217002268f57c74cedc476 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Emmanuel=20Thom=C3=A9?= <Emmanuel.Thome@inria.fr>
-Date: Tue, 7 Jun 2022 12:17:05 -0700
-Subject: [PATCH] patch suggested by @x-YVicto
-
----
- src/lll.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/lll.cpp b/src/lll.cpp
-index 83dab07..f005931 100644
---- a/src/lll.cpp
-+++ b/src/lll.cpp
-@@ -37,7 +37,7 @@
- #ifdef HAVE_FPLLL
- static void lll_fplll (mpz_t *v, mpz_t **M, const int m, const int n)
- {
-- ZZ_mat <mpz_t> Mp (m, n);
-+ fplll::ZZ_mat <mpz_t> Mp (m, n);
- int i, j;
-
- for (i = 0; i < m; i++)
---
-2.36.1
-