summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-09-24 09:27:48 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-12-01 22:06:03 +0100
commit0382e6a4e633d8e95954754475d0887a661c670b (patch)
treefb6553abeffae976998ec2d9637c63f95a6fd0f3
parentc3264f9e100ad6aefe5216002b68f3bfdcf6be95 (diff)
gnu: gobject-introspection: Update to 1.64.1.
* gnu/packages/glib.scm (gobject-introspection) [version]: Update to 1.64.1. [arguments]<#:glib-or-gtk?>: New argument. <#:phases>: Remove all phases. [native-inputs]: Add bison and flex. [inputs]: Remove bison, flex, glib and zlib. [propagated-inputs]: Add glib. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/glib.scm26
1 files changed, 9 insertions, 17 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index a4fa6faefb..eb2d864fa5 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -428,7 +428,7 @@ dynamic loading, and an object system.")
(define gobject-introspection
(package
(name "gobject-introspection")
- (version "1.62.0")
+ (version "1.64.1")
(source
(origin
(method url-fetch)
@@ -437,7 +437,7 @@ dynamic loading, and an object system.")
"gobject-introspection/" (version-major+minor version)
"/gobject-introspection-" version ".tar.xz"))
(sha256
- (base32 "18lhglg9v6y83lhqzyifc1z0wrlawzrhzzxx0a3h1g7xaz97xvmi"))
+ (base32 "19vz7vp10h0zj3f491yk72dp89bix6rgkzxg4qcm4d6151ksxgl0"))
(patches
(search-patches
"gobject-introspection-cc.patch"
@@ -445,25 +445,17 @@ dynamic loading, and an object system.")
"gobject-introspection-absolute-shlib-path.patch"))))
(build-system meson-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'do-not-use-/usr/bin/env
- (lambda _
- (substitute* "tools/g-ir-tool-template.in"
- (("#!@PYTHON_CMD@")
- (string-append "#!" (which "python3"))))
- #t)))))
+ `(#:glib-or-gtk? #t)) ; To wrap binaries and/or compile schemas
(native-inputs
- `(("glib" ,glib "bin")
- ("pkg-config" ,pkg-config)))
- (inputs
`(("bison" ,bison)
("flex" ,flex)
- ("glib" ,glib)
- ("python" ,python-wrapper)
- ("zlib" ,zlib)))
+ ("glib" ,glib "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("python" ,python-wrapper)))
(propagated-inputs
- `(("libffi" ,libffi)))
+ `(("glib" ,glib)
+ ("libffi" ,libffi)))
(native-search-paths
(list
(search-path-specification