summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2020-10-23 22:56:58 +0200
committerJelle Licht <jlicht@fsfe.org>2020-12-04 12:49:03 +0100
commite14bac133cfb7f77d6a0e345f03017f925592d16 (patch)
treeab839ab4983191d29efbf047427ba3880f839aef
parent507c0f0d395d3ae089ed747f722ad3c8347b7394 (diff)
gnu: node: Add node-lts
* gnu/packages/node.scm (node-lts): New package. * guix/build-system/node.scm (default-node): Adjust accordingly.
-rw-r--r--gnu/packages/node.scm136
-rw-r--r--guix/build-system/node.scm2
2 files changed, 137 insertions, 1 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index ffc16bc8a7..03d856aa36 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -622,6 +622,142 @@ definition into a C output.")
compiled and linked with the embedder's program (like @code{Node.js}).")
(license license:expat)))
+(define-public node-lts
+ (package
+ (inherit node)
+ (version "14.15.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://nodejs.org/dist/v" version
+ "/node-v" version ".tar.xz"))
+ (sha256
+ (base32
+ "1g61vqsgq3jsipw2fckj68i4a4pi1iz1kbw7mlw8jmzp8rl46q81"))
+ (modules '((guix build utils)))
+ (snippet
+ `(begin
+ ;; Remove bundled software, where possible
+ (for-each delete-file-recursively
+ '("deps/cares"
+ "deps/icu-small"
+ "deps/nghttp2"
+ "deps/openssl"
+ "deps/zlib"))
+ (substitute* "Makefile"
+ ;; Remove references to bundled software.
+ (("deps/uv/uv.gyp") "")
+ (("deps/zlib/zlib.gyp") ""))
+ #t))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments node)
+ ((#:configure-flags configure-flags)
+ ''("--shared-cares"
+ "--shared-libuv"
+ "--shared-nghttp2"
+ "--shared-openssl"
+ "--shared-zlib"
+ "--shared-brotli"
+ "--with-intl=system-icu"))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (replace 'configure
+ ;; Node's configure script is actually a python script, so we can't
+ ;; run it with bash.
+ (lambda* (#:key outputs (configure-flags '()) inputs
+ #:allow-other-keys)
+ (let* ((prefix (assoc-ref outputs "out"))
+ (flags (cons (string-append "--prefix=" prefix)
+ configure-flags)))
+ (format #t "build directory: ~s~%" (getcwd))
+ (format #t "configure flags: ~s~%" flags)
+ ;; Node's configure script expects the CC environment variable to
+ ;; be set.
+ (setenv "CC" (string-append (assoc-ref inputs "gcc") "/bin/gcc"))
+ (apply invoke
+ (string-append (assoc-ref inputs "python")
+ "/bin/python3")
+ "configure" flags))))
+ (replace 'patch-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Fix hardcoded /bin/sh references.
+ (substitute* '("lib/child_process.js"
+ "lib/internal/v8_prof_polyfill.js"
+ "test/parallel/test-child-process-spawnsync-shell.js"
+ "test/parallel/test-stdio-closed.js"
+ "test/sequential/test-child-process-emfile.js")
+ (("'/bin/sh'")
+ (string-append "'" (which "sh") "'")))
+
+ ;; Fix hardcoded /usr/bin/env references.
+ (substitute* '("test/parallel/test-child-process-default-options.js"
+ "test/parallel/test-child-process-env.js"
+ "test/parallel/test-child-process-exec-env.js")
+ (("'/usr/bin/env'")
+ (string-append "'" (which "env") "'")))
+
+ ;; FIXME: These tests fail in the build container, but they don't
+ ;; seem to be indicative of real problems in practice.
+ (for-each delete-file
+ '("test/parallel/test-cluster-master-error.js"
+ "test/parallel/test-cluster-master-kill.js"))
+
+ ;; This requires a DNS resolver.
+ (for-each delete-file
+ '("test/parallel/test-dns.js"
+ "test/parallel/test-dns-lookupService-promises.js"))
+
+ ;; TODO: why does this fail. It seems to _almost_ pass, but it parses 1 byte?
+ (delete-file "test/parallel/test-http-server-destroy-socket-on-client-error.js")
+
+ ;; TODO: this seems to fail because of spawning processes?
+ (delete-file "test/parallel/test-fs-write-sigxfsz.js")
+
+ ;; FIXME: This test fails randomly:
+ ;; https://github.com/nodejs/node/issues/31213
+ (delete-file "test/parallel/test-net-listen-after-destroying-stdin.js")
+
+ ;; FIXME: These tests fail on armhf-linux:
+ ;; https://github.com/nodejs/node/issues/31970
+ ,@(if (string-prefix? "arm" (%current-system))
+ '((for-each delete-file
+ '("test/parallel/test-zlib.js"
+ "test/parallel/test-zlib-brotli.js"
+ "test/parallel/test-zlib-brotli-flush.js"
+ "test/parallel/test-zlib-brotli-from-brotli.js"
+ "test/parallel/test-zlib-brotli-from-string.js"
+ "test/parallel/test-zlib-convenience-methods.js"
+ "test/parallel/test-zlib-random-byte-pipes.js"
+ "test/parallel/test-zlib-write-after-flush.js")))
+ '())
+
+ ;; These tests have an expiry date: they depend on the validity of
+ ;; TLS certificates that are bundled with the source. We want this
+ ;; package to be reproducible forever, so remove those.
+ ;; TODO: Regenerate certs instead.
+ (for-each delete-file
+ '("test/parallel/test-tls-passphrase.js"
+ "test/parallel/test-tls-server-verify.js"))
+
+ ;; Replace pre-generated llhttp sources
+ (let ((llhttp (assoc-ref inputs "llhttp")))
+ (copy-file (string-append llhttp "/src/llhttp.c")
+ "deps/llhttp/src/llhttp.c")
+ (copy-file (string-append llhttp "/include/llhttp.h")
+ "deps/llhttp/include/llhttp.h"))
+ #t))))))
+ (inputs
+ `(("c-ares" ,c-ares)
+ ("icu4c" ,icu4c-67)
+ ("libuv" ,libuv-node)
+ ("llhttp" ,llhttp-bootstrap)
+ ("google-brotli" ,google-brotli)
+ ("nghttp2" ,nghttp2-1.41 "lib")
+ ("openssl" ,openssl)
+ ("zlib" ,zlib)))
+ (native-inputs
+ (alist-replace "python" (list python-3)
+ (package-native-inputs node)))))
+
(define-public libnode
(package
(inherit node)
diff --git a/guix/build-system/node.scm b/guix/build-system/node.scm
index 560f0ee4da..5737c8ea6e 100644
--- a/guix/build-system/node.scm
+++ b/guix/build-system/node.scm
@@ -39,7 +39,7 @@
"Return the default Node package."
;; Lazily resolve the binding to avoid a circular dependency.
(let ((node (resolve-interface '(gnu packages node))))
- (module-ref node 'node)))
+ (module-ref node 'node-lts)))
(define* (lower name
#:key source inputs native-inputs outputs system target